summaryrefslogtreecommitdiff
path: root/x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild b/x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild
new file mode 100644
index 000000000000..d8ddf1b7c947
--- /dev/null
+++ b/x11-themes/lxqt-themes/lxqt-themes-0.14.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Themes, graphics and icons for LXQt"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.6.0"
+DEPEND=""
+RDEPEND="${DEPEND}"