summaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild')
-rw-r--r--x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
index 2c9744b94635..ecb67cfd24b7 100644
--- a/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
+++ b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
MY_P="gtk-nodoka-engine-${PV}"
DESCRIPTION="GTK+ engine and themes developed by the Fedora Project"
@@ -20,7 +22,16 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${P}-glib2.32.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-glib2.32.patch
+ "${FILESDIR}"/${P}-autoreconf.patch
+ "${FILESDIR}"/${P}-libm.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \