summaryrefslogtreecommitdiff
path: root/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild')
-rw-r--r--x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
index 87de72850d13..c14fd842fb23 100644
--- a/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
+++ b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit gnome2-utils
+inherit xdg-utils
DESCRIPTION="Gargantuan Icon Theme"
HOMEPAGE="https://www.gnome-look.org/content/show.php?content=24364"
@@ -25,6 +25,10 @@ src_install() {
doins -r *
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}