summaryrefslogtreecommitdiff
path: root/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild')
-rw-r--r--x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild34
1 files changed, 6 insertions, 28 deletions
diff --git a/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild
index 9c05a493d77b..370c1e7b7174 100644
--- a/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild
+++ b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit xdg
MY_PN="Chameleon"
@@ -11,15 +13,14 @@ HOMEPAGE="http://www.egregorion.net/2007/03/26/chameleon/"
COLOURS="Anthracite DarkSkyBlue SkyBlue Pearl White"
SRC_URI=""
for COLOUR in ${COLOURS} ; do
- SRC_URI="${SRC_URI} http://www.egregorion.net/works/${MY_PN}-${COLOUR}-${PV}.tar.bz2"
+ SRC_URI="${SRC_URI} mirror://gentoo/${MY_PN}-${COLOUR}-${PV}.tar.bz2"
done
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-S=${WORKDIR}
+S="${WORKDIR}"
src_install() {
dodir /usr/share/cursors/xorg-x11/
@@ -31,26 +32,3 @@ src_install() {
done
done
}
-
-pkg_postinst() {
- elog "To use one of these sets of cursors, edit or create the file ~/.Xdefaults"
- elog "and add the following line:"
- elog "Xcursor.theme: ${MY_PN}-Pearl-Regular"
- elog "(for example)"
- elog
- elog "You can change the size by adding a line like:"
- elog "Xcursor.size: 48"
- elog
- elog "Also, to globally use this set of mouse cursors edit the file:"
- elog " /usr/share/cursors/xorg-x11/default/index.theme"
- elog "and change the line:"
- elog " Inherits=[current setting]"
- elog "to"
- elog " Inherits=${MY_PN}-Pearl-Regular"
- elog
- elog "Note this will be overruled by a user's ~/.Xdefaults file."
- elog
- ewarn "If you experience flickering, try setting the following line in"
- ewarn "the Device section of your xorg.conf file:"
- ewarn " Option \"HWCursor\" \"false\""
-}