summaryrefslogtreecommitdiff
path: root/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
index 42cbbedd2a10..ec449ae6fa1a 100644
--- a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit gnome2
@@ -21,14 +21,15 @@ KEYWORDS="amd64 arm arm64 ppc64 x86 ~amd64-linux ~x86-linux"
# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
-RDEPEND="
- >=x11-themes/hicolor-icon-theme-0.10
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
>=gnome-base/librsvg-2.48:2
"
-DEPEND="${RDEPEND}
- x11-libs/gtk+:3
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
sys-devel/gettext
virtual/pkgconfig
+ x11-libs/gtk+:3
"
# This ebuild does not install any binaries
RESTRICT="binchecks strip"
@@ -51,13 +52,5 @@ src_prepare() {
}
src_configure() {
- # less than 2.45 being a problem is just a guess, but we didn't carry anything between 2.40 and 2.48 in main tree
- if has_version '<gnome-base/librsvg-2.45:2'; then
- ewarn "You are building ${CATEGORY}/${PN} against an older"
- ewarn "gnome-base/librsvg, which will result in various broken symbolic icons until"
- ewarn "rebuild with newer librsvg, and misrendering of scalable icons at runtime"
- ewarn "until gnome-base/librsvg is upgraded!"
- fi
-
gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
}