summaryrefslogtreecommitdiff
path: root/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild')
-rw-r--r--x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild b/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..abf927e9c380
--- /dev/null
+++ b/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
+HOMEPAGE="http://phrat.de/yeahtools.html"
+SRC_URI="http://phrat.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~riscv x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
+)
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+pkg_postinst() {
+ elog "Do not forget to emerge an xterm compatible terminal emulator"
+ elog "(perhaps x11-terms/xterm or x11-terms/rxvt-unicode), or"
+ elog "${PN} will not work ;-)."
+}