summaryrefslogtreecommitdiff
path: root/x11-terms/xfce4-terminal
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xfce4-terminal')
-rw-r--r--x11-terms/xfce4-terminal/Manifest2
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-0.8.10.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/Manifest b/x11-terms/xfce4-terminal/Manifest
index d0d36cc60d85..c6ba46787ba2 100644
--- a/x11-terms/xfce4-terminal/Manifest
+++ b/x11-terms/xfce4-terminal/Manifest
@@ -1,3 +1,5 @@
+DIST xfce4-terminal-0.8.10.tar.bz2 978071 BLAKE2B a74f6037b3ea28ac5561e7251368c0e039a43af1968abab86c44fee5575d1fe9c61b3521be156b48bd7084f7169fdcd9757cb6bfe0c99b539bcb865e9150e358 SHA512 92310837445adf3b611c069d28abea05650b93d54500c0436fb90e0a9be8846122d6ca69f8e6f89a11f2067dc4bfae5557bb11af48d62135b2e5eb395ccdb0f4
DIST xfce4-terminal-0.8.9.2.tar.bz2 945176 BLAKE2B a37a665601c5bdb2f53cd62a0909befaabd9bca0747d477fe369f4e325be15a362d249ae675e6cf707ecc89e623b4b1d73f7a31d32f6c6fcc13e4c57684f5d4b SHA512 1402d913bcc0c050b6c83405c754cdec71cf9bb56e2e68e4396d7ce48bec6e1b0cc875ea3ea2f7a0dff8280d306519fd74a8f9d9ebca383a8f295991cb9ddd94
+EBUILD xfce4-terminal-0.8.10.ebuild 976 BLAKE2B 5dbc856d3799831a58e4d4afdc1ec143278fd08306a7c7439ef6e8e535447296dadd7b57ec65d9ce7fce3ba0d43564a3b1ef95c4d1037a49890f44944f913e14 SHA512 f320148755472bcedc5f934ec01def1b20d92f670cd91a1cc5d47ca8355e749ef7feb41cc1f55b6bca0999ce10ec7c86a299968003e211de6d0986c2dbc01a03
EBUILD xfce4-terminal-0.8.9.2.ebuild 906 BLAKE2B 01069e7fe903b8b1769bc566384646a11b0cc2304efdb0d9a4ebf64aadc4c492d790b421c72e4bc305c6c288fb489b2ff3102bc6ed6101d1056e39043908f446 SHA512 d65079524bb575b840d826ec64d5185d77016f0d52cbbe4a0ecc6b77d241a9549bdd71a57cd8ab3e3016587f64f69863166df59f9fe0870882e367b1ab011fbc
MISC metadata.xml 371 BLAKE2B c8a78256e1d987f23d6e7032a30d180633fd672a451f2b52ac41e3921142280ba9c69556dd3f425b2dfa7438b76fcbc1cdfd4aeadad8a263afeba7173fe43022 SHA512 7035e6d0ab1a3429faa848514df83f35869e291b9bee6cccad20ba5027ffe68b36c4ff371155be31762c4bf904c577a2144ba2a0366b6a4927500b083ccd7ddd
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-0.8.10.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.10.ebuild
new file mode 100644
index 000000000000..444db2416bcd
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-0.8.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="https://docs.xfce.org/apps/terminal/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-3.22:3=
+ x11-libs/libX11:=
+ >=x11-libs/vte-0.46:2.91=
+ >=xfce-base/libxfce4ui-4.14:=[gtk3(+)]
+ >=xfce-base/xfconf-4.14:=
+ utempter? ( sys-libs/libutempter:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}