summaryrefslogtreecommitdiff
path: root/x11-terms/qterminal/qterminal-2.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-2.0.0-r1.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-2.0.0-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/x11-terms/qterminal/qterminal-2.0.0-r1.ebuild b/x11-terms/qterminal/qterminal-2.0.0-r1.ebuild
deleted file mode 100644
index 14dfb83303be..000000000000
--- a/x11-terms/qterminal/qterminal-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg-utils
-
-DESCRIPTION="Qt-based multitab terminal emulator"
-HOMEPAGE="https://lxqt-project.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-2 GPL-2+"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
-DEPEND="
- >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,X]
- x11-libs/libX11
- ~x11-libs/qtermwidget-${PV}:=
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}