summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/files/kitty-0.23.1-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty/files/kitty-0.23.1-flags.patch')
-rw-r--r--x11-terms/kitty/files/kitty-0.23.1-flags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/x11-terms/kitty/files/kitty-0.23.1-flags.patch b/x11-terms/kitty/files/kitty-0.23.1-flags.patch
new file mode 100644
index 000000000000..8f23393f8a0e
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.23.1-flags.patch
@@ -0,0 +1,17 @@
+--- a/setup.py
++++ b/setup.py
+@@ -295,3 +295,3 @@
+ fortify_source = '' if sanitize and is_macos else '-D_FORTIFY_SOURCE=2'
+- optimize = df if debug or sanitize else '-O3'
++ optimize = ''
+ sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+@@ -319,3 +319,3 @@
+ 'OVERRIDE_LDFLAGS',
+- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++ '-Wall ' + ' '.join(sanitize_args)
+ )
+@@ -807,4 +807,2 @@
+ libs.append('-lprofiler')
+- else:
+- cflags.append('-O3')
+ if bundle_type.endswith('-freeze'):