summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild34
1 files changed, 9 insertions, 25 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
index 5166ea870a2d..af803f4eecd4 100644
--- a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
@@ -1,39 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+inherit git-r3
-inherit python-any-r1 xdg git-r3
-
-DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
-HOMEPAGE="https://github.com/kovidgoyal/kitty"
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug"
-
-DEPEND="${PYTHON_DEPS}"
+RESTRICT="test" # intended to be ran on the full kitty package
-PATCHES=(
- "${FILESDIR}"/kitty-terminfo-setup-0.20.1.patch
-)
+BDEPEND="sys-libs/ncurses"
-# kitty-terminfo is a split package from kitty that only installs the terminfo
-# file. As tests are designed to be run with the whole package compiled they
-# would fail in this case.
-RESTRICT="test"
-
-src_compile() {
- "${EPYTHON}" setup.py \
- --verbose $(usex debug --debug "") \
- --libdir-name $(get_libdir) \
- linux-terminfo || die "Failed to compile kitty."
-}
+src_compile() { :; }
src_install() {
- insinto /usr
- doins -r linux-package/*
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
}