summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin28061 -> 28063 bytes
-rw-r--r--x11-plugins/pidgin-telegram/Manifest2
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild53
-rw-r--r--x11-plugins/vicious/Manifest6
-rw-r--r--x11-plugins/vicious/metadata.xml7
-rw-r--r--x11-plugins/vicious/vicious-2.3.3.ebuild28
-rw-r--r--x11-plugins/vicious/vicious-2.5.0.ebuild64
-rw-r--r--x11-plugins/wmmaiload/Manifest1
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild48
9 files changed, 127 insertions, 82 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 255f8c74a4f8..16cf204f8cc0 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index 398c77ed3824..bc7fa2f02b41 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1,4 +1,6 @@
AUX pidgin-telegram-1.4.3-clang.patch 3674 BLAKE2B c1fb52b984168afcd576b429ab97f92b44a04bdbe39af9f98c71a76bb0a18c9b82a0b7e16a5dd0c70cbd0d743a3a597b2cae9eea9ee04cb98674699452b0fea2 SHA512 f855a52582dc05266e3ac1410af668f6ce6e7f9a074d514b07c5d7c39b317f338967c41732f56db427bd3ab33b91af67d0df354ae1d43663abc45fd4edacfd02
DIST telegram-purple_1.4.4.orig.tar.gz 495386 BLAKE2B 7ecac3a334f88f3d9c0367c5910d3de03b1e6749f18628a58f90c0ae3602dd04d0a1bec79b1016af236375bfe3eb7d4c40437c31fbbee0e9648e5425e40bb43d SHA512 9907da48b978294749f0697313cc7dbf26358535d6528190d8b61cdce5e478af8e756528a212af806025eb75b7f7ec90054ee763eea327f101ef469d0f4fd43e
+DIST telegram-purple_1.4.6.orig.tar.gz 497757 BLAKE2B 1f666aaf4ef1913420cf735e3d85e1d91be8a2f07932785d55bc0be37e2cd8cabaf6b0be2b520afafc6636a692086be180d3bd4438215f8b14ae867da9891e18 SHA512 bf3e14a2d1dec7382833011ea891ba5bce81820766b3d6adee582bf0257baadeb7aa7eab7aa6e20adf8dd7728eb653db35b1d8f56bfffe7a92f9bf7506401e6e
EBUILD pidgin-telegram-1.4.4.ebuild 1242 BLAKE2B 2981f5225498ee1b2cd78d2891e59fea80bac0bfc903f297b3e56e74f6f7bb402020089a00ec918ddce67c17b7cba40a286325f7f51afb7c6d61c3471c0d3b29 SHA512 35e07021eb2f97d931fc2805d30c9ae4911b7d6c990d7de7cdb6ca733993df9de53843049fe90e716b62d2a4bc8c71b0d356722e6ddd03205d37cdbaa2c6727a
+EBUILD pidgin-telegram-1.4.6.ebuild 1191 BLAKE2B a11bb41ddd06c91f62ab4ee173529d999606017a2da51f622b6057a9d5d61446eef95b7abdc8342da7ad9b22984aa6d036dd819668803fa883fa125090f17712 SHA512 5e89c5623800a170276af0bb519a5fb7d3fbfdf911e6309fa2d62b6520f322c63c383f3e42c75829f96a612620b666c008fc93b5ff4348c37ec25ae52128fa3e
MISC metadata.xml 722 BLAKE2B fb8498a592b6da08fda5cb1961fd84ea2a4e839233719330625166f487f2d01e8000860d2383488ea1c377105f8d74aae928871f349ed08efda1dd7c0420db10 SHA512 6b7e5121c5662de9943b7b7d30e6acf6c2df04b5c9d19b3ce942b6e403e62023f1a07076c4023d899ccb97f7fd2a29b331f9bf76391cb5db1c477d5bfce088c8
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
new file mode 100644
index 000000000000..06014ab6c69c
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+S="${WORKDIR}/telegram-purple"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt libressl +nls +png +webp"
+
+RDEPEND="
+ net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+ png? ( media-libs/libpng:0= )
+ webp? ( media-libs/libwebp:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable png libpng)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index cb6d1af0ba60..318ba09a97cf 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1,5 +1,5 @@
DIST vicious-2.3.1.tar.gz 47484 BLAKE2B 2ef6e51507faf7477800091c738e65184439caba9b79004b53f3a479f1370ca64046bc1664c6b746d8ab71370b36f29095406439e2a8fab7524e6bb190350fb7 SHA512 9e89d36d708a7ccdff206451dfb98db8455a16f9d2254167a446af91fadc2103a5274442f38ddf1eb919da23480b6790639cdbbde4a08bffc1cf9221622064c9
-DIST vicious-2.3.3.tar.gz 50564 BLAKE2B f472b9e1514c9f731734e6512496da6ebb516a190225035811333ca7a275509828b8b4078d72856b5a488eeaee612e3070406138f1abd9de61aaa0f01ca370b9 SHA512 2549fa168a8c8cebcb9ecf1eafbc7658213b6a5487839e8acbc2aaed18f0d0b8081550ee7beb93770ae7e600158e12b99b9e1c29af8a8807bb200cc1cdf75807
+DIST vicious-2.5.0.tar.gz 67557 BLAKE2B ffbc1b3c0e32b554cc367a51e5e17130e1b9f7fed2e8505aaa1845719ecd6d465d43ba839ac3a9b73a87e43ff3144c2074f3750d5f67b516d033a74144e9e12f SHA512 deb21587d1d7f2e6e4dd77c74abbfa337acf6c99ef9bebc0e505f1508afc6e3b03f043a639f866fcda0191447c103d3fba51376682201482fb669a263321dee5
EBUILD vicious-2.3.1.ebuild 670 BLAKE2B a96e57a97480303b302d1c387de5f9ee8d86173af0c1ccbc3b100a8292a6bbe0b0e679f930eb881b66d655640bf10b3d95052e468181d1baf31e68cda6a3ae4c SHA512 0a1ae727bca18f54e06a4df1cea575328a10604dc85046e1f1ec242eeb22e4d57544ecc2bc6c349b538b1cead65840f75a2797aa41ee70595a33f5c3810d13d0
-EBUILD vicious-2.3.3.ebuild 669 BLAKE2B aa05171e4521066dac77d884ef9ddc719bf2475a2932c6cd1da4ea9440bb41204f569785ca8e9034b31fdb5f3b5ffc1d8162ebb027d9ffb5355f69c59bfab5f6 SHA512 11cb386ea966f246e768cc0490b6406e67e018d2961f9607f845891a385f358ff58a012ffeabf2118c86377b8390b9c5e2cbe67202b40c950aa40edc29f86fa7
-MISC metadata.xml 383 BLAKE2B 91e0094887c3d3ea1e60d96006a87a6fc30fbb58ad329575ce323268a95e7c0d963981c2aa2a5fb10146912e8decc2939e92419a2084af4315e3ce18d3948dbd SHA512 106a9e2d26d2949596de091c1de5cf86d113fca6868b883292d3b254044b3321deefe6f671542b041d500714006ac0c78abf4c6b45eb94c3cb64b7b39144f22d
+EBUILD vicious-2.5.0.ebuild 2267 BLAKE2B d1bc5ce6e86510954ccf86fea58e75e15e9f59f3ecf414f902fe1b9cf40de084b32a2fb56b7bdd13f62a8485b30d37a629b2d8382bd699c1cbe1fc24c2f7722a SHA512 5b7e40b7fbfe4e58b60c26bdee583783b36dfc349f65c460c7ceda87b037367faa6fc9262e7bb05918987bd7c0ebb34d82beecea7365659b1a938feea5a1ec37
+MISC metadata.xml 467 BLAKE2B e2275dacd87f47bbca44c35c04695410193e190a0c478d359f2834d4f1a07e24f887dfddd91efc844a453ec15286e638efda98a31eca6e0539861d3f2cd6b39c SHA512 20b743701dabb4a037d6720a4d6ebc29d1abecffc60cf191b6b799c87192dbdac3e11b68d5cfb3b9b6f1a275e50bd1ce8d2d6eb1a157f6b68f83416652ce2122
diff --git a/x11-plugins/vicious/metadata.xml b/x11-plugins/vicious/metadata.xml
index 2af1ac6d48e5..1618c3ef94e3 100644
--- a/x11-plugins/vicious/metadata.xml
+++ b/x11-plugins/vicious/metadata.xml
@@ -2,10 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>maksbotan@gentoo.org</email>
- <name>Maxim Koltsov</name>
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<use>
<flag name="contrib">Install extra widgets, some for less common hardware, some contributed by Vicious users.</flag>
</use>
+ <upstream>
+ <remote-id type="github">vicious-widgets/vicious</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-plugins/vicious/vicious-2.3.3.ebuild b/x11-plugins/vicious/vicious-2.3.3.ebuild
deleted file mode 100644
index 4934c0636f0d..000000000000
--- a/x11-plugins/vicious/vicious-2.3.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Modular widget library for x11-wm/awesome"
-HOMEPAGE="https://github.com/Mic92/vicious"
-SRC_URI="https://github.com/Mic92/vicious/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="contrib"
-
-DEPEND=""
-RDEPEND="x11-wm/awesome"
-
-src_install() {
- insinto /usr/share/awesome/lib/vicious
- doins -r widgets helpers.lua init.lua
- dodoc Changes.md README.md TODO
-
- if use contrib; then
- insinto /usr/share/awesome/lib/vicious/contrib
- doins contrib/*.lua
- newdoc contrib/README.md README.contrib
- fi
-}
diff --git a/x11-plugins/vicious/vicious-2.5.0.ebuild b/x11-plugins/vicious/vicious-2.5.0.ebuild
new file mode 100644
index 000000000000..32f7e2f8ca29
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/vicious-widgets/vicious"
+SRC_URI="https://github.com/${PN}-widgets/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets helpers.lua init.lua
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Note that as of 2.5.0 this list may or may not be incomplete - it has been produced
+ # only by searching for occurrences of vicious.spawn (the recommended way of calling
+ # external helpers because it supports async) and popen (still used by many contrib widgets).
+ # Moreover, dependencies of all non-Linux widgets have been excluded on purpose.
+ elog "These widgets need some dependencies:"
+ optfeature "cmus" "media-sound/cmus"
+ optfeature "fs" "sys-apps/coreutils" # df
+ optfeature "gmail" "net-misc/curl"
+ optfeature "hddtemp" "net-misc/curl[telnet] app-admin/hddtemp"
+ optfeature "hwmontemp" "sys-apps/grep"
+ optfeature "mdir" "sys-apps/findutils"
+ optfeature "mpd" "net-misc/curl[telnet] media-sound/mpd"
+ optfeature "notmuch" "net-mail/notmuch"
+ optfeature "volume" "media-sound/alsa-utils" # amixer
+ optfeature "weather" "net-misc/curl"
+ optfeature "wifi" "net-wireless/wireless-tools"
+ optfeature "wifiiw" "net-wireless/iw"
+ if use contrib; then
+ optfeature "contrib/btc" "net-misc/curl"
+ optfeature "contrib/buildbot" "net-misc/curl"
+ optfeature "contrib/countfiles" "sys-apps/findutils"
+ optfeature "contrib/mpc" "media-sound/mpc"
+ optfeature "contrib/openweather" "net-misc/curl"
+ optfeature "contrib/netcfg" "sys-apps/coreutils" # ls
+ optfeature "contrib/nvinf" "x11-drivers/nvidia-drivers" # nvidia-settings
+ # ossvol needs 'ossmix' - not packaged?
+ optfeature "contrib/pulse" "media-sound/pulseaudio" # pacmd
+ optfeature "contrib/rss" "net-misc/curl"
+ optfeature "contrib/sensors" "sys-apps/lm-sensors"
+ optfeature "contrib/wpa" "net-wireless/wpa_supplicant" # wpa-cli
+ fi
+ elog
+}
diff --git a/x11-plugins/wmmaiload/Manifest b/x11-plugins/wmmaiload/Manifest
index c952b8ba228b..25756e9392ea 100644
--- a/x11-plugins/wmmaiload/Manifest
+++ b/x11-plugins/wmmaiload/Manifest
@@ -2,6 +2,5 @@ AUX wmmaiload-2.2.1-checkthread.patch 387 BLAKE2B 2c79203a230b8caa9cb3ff85443380
AUX wmmaiload-2.3.0-fno-common.patch 3189 BLAKE2B ce81f29d6b8fb3c95eaeb1859d86cd45a935e595785c26ee756cdebf8b9f7f340b966020796c6ee96d943b3aea7ff81df48d3c05af6119d31cf6c81d5748a2a9 SHA512 689c196834783f969c58d3a3244eb289c0d0a34b7a9c32f9b374f07325b3077f8e231afa1fe91832d0e99e4cc2a54c6a85cf9839bec65a588288e57df60804d3
AUX wmmaiload-2.3.0-ssl.patch 1008 BLAKE2B 2d62d5549df7facd43df932365bccb11324c90ec79dc0aedc1fc42bde5474aa82c51ab42420bda06d6ae2282d26c8cc8aaf59597bbdee4fdebcec31b0ba509f3 SHA512 2976bba5207b77c80ceb0d1759a170f03915fe7746f051a07a1862e748e1d9f95b717670c5ef7692de8fa995b1a1bf018a15f1ec8a70165dcbe5dff691c12352
DIST wmmaiload-2.3.0.tar.bz2 42852 BLAKE2B abee44716ff74e48a480881c3327bc4a4f02600044a587b3322429567a3454f01c733542fbaa42cb074a2da48ecd1c453d19ed42c30efc04e634c44330d729d3 SHA512 c4e63eb2868474e3b76f5f4f401bdd23172f23dfdb0e90712e3eca607494057e067805b83a53490d38b6f7b2c876e2ec8fdb1d95b871d3febeeda35369550de9
-EBUILD wmmaiload-2.3.0-r1.ebuild 1113 BLAKE2B a3cd913239de19f6a5ff5e14fb29eef7604b8b1905aa64032b8b327a73dad27a0c6d08eaac75c01cbd64f3b4f576d1e5694e5318bb9f825a182c1ee3e17ad9b9 SHA512 a72ed432d9bb9a1a74ef9d8871d41a6ce92a5afd44394a9b0c51f51b7ce0f85fcd450bac3858ef93c946b9852577d7dfc831eaf1e0b2e39b4f2305655995570d
EBUILD wmmaiload-2.3.0-r2.ebuild 1031 BLAKE2B e554130a4e6ac20409aa49bc908a787ef36627447da5c63b7903ab22638f411a448dac5100c30fd45b66a30dead92112c264b6dc0425688e53f5beeef106242e SHA512 ca8ddb91ce97a04517a0cb62fd645667e7c3d0dc9f84b00a7bf3f508428f3961630f15d6fa8bfcf7645f6af930bc7f56b2789d765d4e5efca03fa0a7d16cdcbd
MISC metadata.xml 249 BLAKE2B ba223d81d4cf6b9ca1ba3a63e356bec0d9aa6f4cdf2ad3b29a6c97a6e5bad854154f8b9e6fc3d65d155c93daa706d03c84395b53951e3e326ffc19c8d0df0eb5 SHA512 1a1312bb0e9f74f1e3852218d8fd4817fbad3bc65633cecbe8735607bc33c1e05b414c2628ff3f6e24dfc4a3999de7191f6cdadd2161b03cf614d5b6f24fab8d
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild
deleted file mode 100644
index c0e09e894497..000000000000
--- a/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-DESCRIPTION="dockapp that monitors one or more mailboxes"
-HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
-SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/gtk+:2
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.2.1-checkthread.patch )
-src_prepare() {
- sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die
- sed -e "s/SSLv2_client_method/SSLv23_client_method/" \
- -i wmmaiload/ssl.c || die
-
- default
-}
-
-src_configure() {
- # The ./configure script is not autoconf based, therefore don't use econf:
- ./configure -p /usr || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- DEBUG_LDFLAGS="" \
- LDFLAGS="${LDFLAGS}" \
- DEBUG_CFLAGS=""
-}
-
-src_install() {
- dobin ${PN}/${PN} ${PN}-config/${PN}-config
- doman doc/*.1
- dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
-}