summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26089 -> 26087 bytes
-rw-r--r--x11-plugins/wmdiskmon/Manifest2
-rw-r--r--x11-plugins/wmdiskmon/files/wmdiskmon-0.0.2-include.patch12
-rw-r--r--x11-plugins/wmdiskmon/wmdiskmon-0.0.2-r2.ebuild30
4 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 9169b308cb16..80e5e1f6d5c3 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/wmdiskmon/Manifest b/x11-plugins/wmdiskmon/Manifest
index eec6e7337898..08cfc6dbcb41 100644
--- a/x11-plugins/wmdiskmon/Manifest
+++ b/x11-plugins/wmdiskmon/Manifest
@@ -1,3 +1,5 @@
+AUX wmdiskmon-0.0.2-include.patch 216 BLAKE2B c4f41ffb09ab162f9b4a852b99366c05061505e8b79be7ed1a93aa4c7a0d730692dcbcc079b82f6d671aac68d18fb030593b6f1bb346b422fde60f80d7c87a8d SHA512 addb0605af2a8dbc5cc683b20df77d0bff6f893ba64bbc8163977326bea270dc898ab96fdfce529956e7ed4b07ceceeace13c2c1851b1f49ad6a1d6c2c184e8b
DIST wmdiskmon-0.0.2.tar.gz 91996 BLAKE2B ecf4b9ed151dc9bef1dd6e68f7b62af77774b6527d37b833527a45caf56cf7f58e70cb2b78e4e2c13cee063532fcc81418ce0b5e0f4c8b7d177cf03a11e21c0f SHA512 c39c298961129fc6951d27096c2993b0cafcba52b5898518fdb6f446b6fd6332db1df36bd1c812f1b1ab7fb0c59759f749176a675a29eb271a72430709ef550b
EBUILD wmdiskmon-0.0.2-r1.ebuild 468 BLAKE2B 4c6ff50966c780517fe81e51d068077d3e5f24f64d721cad1f11d65290fb88a2a68f8d3971bac172d6ee01f1545e3e15ba72c658af2568ddc8c312b1f6c6b863 SHA512 15a9bb8e1b1499894b0c58531a3e45d4a03c6c4125cf9f289ecdbcf6d36a1ae340b3af3c617dff808b50e3d9ea5bc464b71cb4aadab6519c406b21052f949647
+EBUILD wmdiskmon-0.0.2-r2.ebuild 606 BLAKE2B 8845aed3c8c570319e5571256d01d6148703c4cc8cf08e41f425355b3dd4159fb72e2150aeeac488b16b37022768d90e216a7319be797bffc3b39151747dc581 SHA512 7944d40eb69fc266a42346e21445dcfba44d0cba40e21e1a3294812a3be68d38644e46ae20b1d64df36fd0e4092f6581ecc2854af5b6c4ba1993daff778bbf06
MISC metadata.xml 250 BLAKE2B 3d69a837b82fe334630573d6bf123718a3eac254377bc2ca86a2268f210cbcef9922db631e91954bceacc28828b54ad567d0568a4df655545ac56a4a54151d76 SHA512 ee587c14474743ca118c5468d1cd04ce5e3533ea29550ae74a7d517f092c895fa18c7edc7e9ffe7757b62c214dda7abf5352ee838a6dbd7d1079d60d2762732f
diff --git a/x11-plugins/wmdiskmon/files/wmdiskmon-0.0.2-include.patch b/x11-plugins/wmdiskmon/files/wmdiskmon-0.0.2-include.patch
new file mode 100644
index 000000000000..5c689cd41d7b
--- /dev/null
+++ b/x11-plugins/wmdiskmon/files/wmdiskmon-0.0.2-include.patch
@@ -0,0 +1,12 @@
+Add missing include
+https://bugs.gentoo.org/878641
+--- a/src/main.c
++++ b/src/main.c
+@@ -25,6 +25,7 @@
+ #include "config.h"
+ #endif
+
++#include <ctype.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/x11-plugins/wmdiskmon/wmdiskmon-0.0.2-r2.ebuild b/x11-plugins/wmdiskmon/wmdiskmon-0.0.2-r2.ebuild
new file mode 100644
index 000000000000..47941d1996f6
--- /dev/null
+++ b/x11-plugins/wmdiskmon/wmdiskmon-0.0.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="a dockapp to display disk space usage"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}/${P}-include.patch" )
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/908911
+ eautoreconf
+}