summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26119 -> 26103 bytes
-rw-r--r--x11-plugins/pidgin-birthday-reminder/Manifest3
-rw-r--r--x11-plugins/pidgin-birthday-reminder/files/pidgin-birthday-reminder-1.13-includes.patch94
-rw-r--r--x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r2.ebuild (renamed from x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r1.ebuild)4
-rw-r--r--x11-plugins/pidgin-encryption/Manifest4
-rw-r--r--x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-includes.patch432
-rw-r--r--x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-time.patch135
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r3.ebuild (renamed from x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r2.ebuild)10
-rw-r--r--x11-plugins/pidgin-otr/Manifest3
-rw-r--r--x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-includes.patch22
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r4.ebuild1
11 files changed, 702 insertions, 6 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 270cec0e0514..a63ed68b3504 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/pidgin-birthday-reminder/Manifest b/x11-plugins/pidgin-birthday-reminder/Manifest
index af72b8d8a189..150b565172c3 100644
--- a/x11-plugins/pidgin-birthday-reminder/Manifest
+++ b/x11-plugins/pidgin-birthday-reminder/Manifest
@@ -1,3 +1,4 @@
+AUX pidgin-birthday-reminder-1.13-includes.patch 1967 BLAKE2B f0841f1306b0b18433774baec445034a29a2b677957eee2a394050715a3331cfa6c61957c5d3a9f8fca82a7a20b051fb880dc96d9ac2c9aa7bd619b3e750d4d9 SHA512 b1fd862bbb0292a39e48d9a5e74cb30143e34480ad9e7cb6656a2b15338d0d9658a38e8f7af7ad54cef2cfe774d50b3cecd27cf90948799549660c9e0e1d5ce1
DIST pidgin-birthday-reminder-1.13.tar.gz 535270 BLAKE2B a49477046b99b3949e72d120ca4f09164d3b844d15b5232eacf8c076d7e2dca629a391fe6c86d69d15d77996a6c0a32224126115cd799b7d77dc31a46a9bd69d SHA512 c858c99c01c1105074d2ece46b8f6dbbf4045ee34dee046286a64b1886e32df416d844070a061a6fc8841d9e698f7d129fcf0b0079de0b24a5baf9a2f0b90e75
-EBUILD pidgin-birthday-reminder-1.13-r1.ebuild 856 BLAKE2B 168f8dc27bbdd35c62ebfc506ac4e74088c14791125b3ece83dfd0ea8517dfd4e3646a82967fcf26eda8514cc4de32e3511dbfadefcf9fba761aa492045ad815 SHA512 f09c7a5f95196bf102cacd6f4f330378e83083f39842711a6903bd00f0366eeceb6593b44dba40e1dd24c631a9cd32e37e83160cb64db055cff4facaf50e45d1
+EBUILD pidgin-birthday-reminder-1.13-r2.ebuild 910 BLAKE2B eca5b12df4c565f777cfc944ba9a680f330d1dc72d1fad8ab77a765f9e96d267ca6913587c04989358d9473bbf8db2cf7e35d01d5bca8fc806a4a46005a49c41 SHA512 3904f148e63f58746c43a9ed48d8c46a6b74c68ddca7f3957db7ddad1fc7f2b25d7d6b9faa54a0f3b87c7d4f2f2809e5ada0d9ed2c7908a05748cf2a1f9e16dd
MISC metadata.xml 417 BLAKE2B affbf9d75c532539089ff900044cafdee2ae9af99efb2968d655683b7a896bb24d32b3334fd0f248717f672dce8b74da8ecb277fb0dd62e483f80ef45c6bfc5e SHA512 7a5599a222ca31952bd8f18b3a1ff3cb332d2bf8977dff95e659a0ab0b00fb568c240c0979927f282a5cfc77428e1bbee93a7206646c324424f97c112d7919de
diff --git a/x11-plugins/pidgin-birthday-reminder/files/pidgin-birthday-reminder-1.13-includes.patch b/x11-plugins/pidgin-birthday-reminder/files/pidgin-birthday-reminder-1.13-includes.patch
new file mode 100644
index 000000000000..4c3b64ff8b88
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/files/pidgin-birthday-reminder-1.13-includes.patch
@@ -0,0 +1,94 @@
+--- a/src/emblems.c
++++ b/src/emblems.c
+@@ -26,9 +26,9 @@
+ #include "birthday_access.h"
+ #include "pidgin_internals.h"
+
+-#include <glib.h>
+-#include <gtkblist.h>
+-#include <debug.h>
++#include <glib-2.0/glib.h>
++#include <pidgin/gtkblist.h>
++#include <libpurple/debug.h>
+
+ extern PurplePlugin *plugin;
+ PidginBuddyList *gtkblist = NULL;
+--- a/src/icsexport.c
++++ b/src/icsexport.c
+@@ -22,8 +22,8 @@
+ #include "internal.h"
+ #include "birthday_reminder.h"
+
+-#include <prefs.h>
+-#include <debug.h>
++#include <libpurple/prefs.h>
++#include <libpurple/debug.h>
+
+ #include <stdio.h>
+
+--- a/src/notification.c
++++ b/src/notification.c
+@@ -22,12 +22,12 @@
+ #include "internal.h"
+
+ #include <gtk/gtk.h>
+-#include <sound.h>
+-#include <debug.h>
+-#include <request.h>
+-#include <gtkutils.h>
+-#include <gtkblist.h>
+-#include <pidginstock.h>
++#include <libpurple/sound.h>
++#include <libpurple/debug.h>
++#include <libpurple/request.h>
++#include <pidgin/gtkutils.h>
++#include <pidgin/gtkblist.h>
++#include <pidgin/pidginstock.h>
+
+ #include "birthday_reminder.h"
+ #include "functions.h"
+--- a/src/pidgin_internals.c
++++ b/src/pidgin_internals.c
+@@ -22,7 +22,7 @@
+ #include "birthday_reminder.h"
+ #include "internal.h"
+
+-#include <debug.h>
++#include <libpurple/debug.h>
+
+ extern PidginBuddyList *gtkblist;
+
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -22,11 +22,11 @@
+
+ #include "prefs.h"
+
+-#include <debug.h>
++#include <libpurple/debug.h>
+
+ #include <gtk/gtk.h>
+-#include <gtkblist.h>
+-#include <gtkutils.h>
++#include <pidgin/gtkblist.h>
++#include <pidgin/gtkutils.h>
+
+ #include "birthday_reminder.h"
+ #include "icsexport.h"
+--- a/src/scan.c
++++ b/src/scan.c
+@@ -21,10 +21,10 @@
+
+ #include "internal.h"
+
+-#include <glib.h>
+-#include <connection.h>
+-#include <debug.h>
+-#include <accountopt.h>
++#include <glib-2.0/glib.h>
++#include <libpurple/connection.h>
++#include <libpurple/debug.h>
++#include <libpurple/accountopt.h>
+
+ #include "birthday_reminder.h"
+ #include "check.h"
diff --git a/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r1.ebuild b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r2.ebuild
index 64bf7e041a0a..fd8c3e0b0d62 100644
--- a/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r1.ebuild
+++ b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.13-r2.ebuild
@@ -18,6 +18,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13-includes.patch
+)
+
src_configure() {
econf \
$(use_enable static-libs static)
diff --git a/x11-plugins/pidgin-encryption/Manifest b/x11-plugins/pidgin-encryption/Manifest
index f412efdfadf0..133a12983143 100644
--- a/x11-plugins/pidgin-encryption/Manifest
+++ b/x11-plugins/pidgin-encryption/Manifest
@@ -1,4 +1,6 @@
AUX pidgin-encryption-3.1-glib2.32.patch 381 BLAKE2B 0f62640d14f2da191de008f7a5a984d2a1462400eccc9c83e890fbdb0e4be271cac9e692af2619307de95ddc198e2d0e19a36dde55d617ddcdd69d15f90455df SHA512 1c6b3c34d0e8acab7dd4465348d674b56d8939305e87dc9e59bd14e99e7123e865c4e6a91f641e3365c507b2d88e19541f05534b3255ab23754d95d49c997639
+AUX pidgin-encryption-3.1-includes.patch 8580 BLAKE2B 9feefec902d1548cfcce626d1a1065eaa4c273bbb796f172b0e354cbf418189faf82812a2e0e7797265a7e167dbb976db24078227a87bd8bf33b6f20674267bc SHA512 146682b40a9a104f38482bb61b5f101b39de72be7ce1963b96065c1aa5bfa9dc0fa424d8b447b5209efa8456b82edb8ce8f5f1926b8fe54c4ada25ecab3ebe43
+AUX pidgin-encryption-3.1-time.patch 5624 BLAKE2B 0f02e2a221c21d5588a7346e3b19b2364fef3cd7b4360fd6af528529d8c29d9ee54c48eec5b8f047826c8d5bfd465051a28f01e5be6fd74f312e00a80368fc7d SHA512 d412ffd92104994d46aa9dcd44bbd230d41ca9f62784334fd1e960413d674519fecba53fa254e4ac9820b17030ef8fb0f93232bb33e19f2cdd44fd8ddc76e3e5
DIST pidgin-encryption-3.1.tar.gz 604129 BLAKE2B d42c6baf9e1b0adcb8e88a611279fa66f6c37ce3e89c742c6a8e2662662576cc9e08c8e3fa08c19e857b88165b840826f9118c5bcca0098b7eb02fac0a8ae159 SHA512 681e719dacc6812f6e965b5025631b02dc6abe4694c4dfc3034d5c07e97798707f28920c142b99f9d428470ef5c14bffe5d7c62d2d5fce01ad0e7567ab60b32d
-EBUILD pidgin-encryption-3.1-r2.ebuild 756 BLAKE2B 008326df4c5a92146207305887532dd4c25823229a88aa0644b4c82c098e294ab6dae644d66465f6ceb99f98bd10e1a31ff3548d583cefb25b884be0e60f4993 SHA512 097f9969a49f9733da7a34c041bc18b5d39e42c602f65ee6b3da9ec38ed4d36ad4e251ee5e03f73eda64e9e0c194afede97bd238c5ee403754abf76df5593e41
+EBUILD pidgin-encryption-3.1-r3.ebuild 857 BLAKE2B 0f90ad602f8662e3139a37b6252bbaa8f56a3251168553f308561c84c2e682217cdccc149d370834acdcb1772d182e79dc11e81d1fad0dd9629c503501c87092 SHA512 7bddf850b1629e66cbb117839bb2ed29c952c80540205abdfb2202f16d615d8ec9e4ad5a23376a21322b772f11694197503c4f1cc839b9c1bfb0b64fb599ff4f
MISC metadata.xml 252 BLAKE2B da1c7143f1c37f82af4d63c2053380e315cb3770bc65f5c8b43ee4c3f3858b54ec0a83db45d55f4a01743cc0db7b44ab0dd67698b1e2e4ca25fe81f14d94ee01 SHA512 d2416e5d0af9155bf7b99405a2f766be24b2e5062651cbcecf1b9546a3a91512edc5d0ae14b1c10db579b459169a201db2a870465d9a34c058eef0654c40eb5c
diff --git a/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-includes.patch b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-includes.patch
new file mode 100644
index 000000000000..4ea82aee5619
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-includes.patch
@@ -0,0 +1,432 @@
+https://bugs.gentoo.org/932530
+--- a/config_ui.c
++++ b/config_ui.c
+@@ -24,11 +24,10 @@
+ #include <gtk/gtk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <debug.h>
+-#include <gtkdialogs.h>
+-#include <gtkprefs.h>
+-#include <gtkprefs.h>
+-#include <util.h>
++#include <libpurple/debug.h>
++#include <pidgin/gtkdialogs.h>
++#include <pidgin/gtkprefs.h>
++#include <libpurple/util.h>
+
+ #include "nls.h"
+ #include "cryptproto.h"
+--- a/config_ui.h
++++ b/config_ui.h
+@@ -18,7 +18,7 @@
+ #ifndef CONFIG_UI_H
+ #define CONFIG_UI_H
+
+-#include <plugin.h>
++#include <libpurple/plugin.h>
+
+ extern GtkWidget* PE_get_config_frame(PurplePlugin *plugin);
+ extern void PE_config_cancel_regen(void);
+--- a/cryptproto.h
++++ b/cryptproto.h
+@@ -18,7 +18,7 @@
+ #ifndef CRYPTPROTO_H
+ #define CRYPTPROTO_H
+
+-#include "debug.h"
++#include <libpurple/debug.h>
+
+ #include "rsa_nss.h"
+
+--- a/cryptutil.c
++++ b/cryptutil.c
+@@ -27,7 +27,7 @@
+ #include <unistd.h>
+
+
+-#include <debug.h>
++#include <libpurple/debug.h>
+
+ #ifdef _WIN32
+ #include <win32dep.h>
+@@ -37,7 +37,7 @@
+ #include "cryptutil.h"
+ #include "rsa_nss.h"
+
+-#include <base64.h>
++#include <nss/base64.h>
+
+
+
+--- a/cryptutil.h
++++ b/cryptutil.h
+@@ -18,7 +18,7 @@
+ #ifndef CRYPTUTIL_H
+ #define CRYPTUTIL_H
+
+-#include "debug.h"
++#include <libpurple/debug.h>
+
+ #define MSG_HUNK_SIZE 126
+ #define CRYPT_HUNK_SIZE 256
+--- a/encrypt.c
++++ b/encrypt.c
+@@ -24,20 +24,20 @@
+ #include <gdk/gdk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <debug.h>
+-#include <core.h>
+-#include <gtkutils.h>
+-#include <gtkplugin.h>
+-#include <gtkconv.h>
+-#include <gtkdialogs.h>
+-#include <gtkprefs.h>
+-#include <blist.h>
+-#include <gtkblist.h>
+-#include <gtkimhtml.h>
+-#include <gtklog.h>
+-#include <signals.h>
+-#include <util.h>
+-#include <version.h>
++#include <libpurple/debug.h>
++#include <libpurple/core.h>
++#include <pidgin/gtkutils.h>
++#include <pidgin/gtkplugin.h>
++#include <pidgin/gtkconv.h>
++#include <pidgin/gtkdialogs.h>
++#include <pidgin/gtkprefs.h>
++#include <libpurple/blist.h>
++#include <pidgin/gtkblist.h>
++#include <pidgin/gtkimhtml.h>
++#include <pidgin/gtklog.h>
++#include <libpurple/signals.h>
++#include <libpurple/util.h>
++#include <libpurple/version.h>
+
+ #include "cryptproto.h"
+ #include "cryptutil.h"
+--- a/encrypt.h
++++ b/encrypt.h
+@@ -24,7 +24,7 @@
+ #include "pidgin-encryption-config.h"
+ #endif
+
+-#include <conversation.h>
++#include <libpurple/conversation.h>
+ #define ENC_WEBSITE "http://pidgin-encrypt.sourceforge.net"
+
+ #define CRYPTO_SMILEY "PECRYPT:"
+--- a/keys.c
++++ b/keys.c
+@@ -17,9 +17,9 @@
+
+ #include "internal.h"
+
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+ #if GLIB_CHECK_VERSION(2,6,0)
+-# include <glib/gstdio.h>
++# include <glib-2.0/glib/gstdio.h>
+ #else
+ # define g_freopen freopen
+ # define g_fopen fopen
+@@ -37,8 +37,8 @@
+ #include <gtk/gtk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <debug.h>
+-#include <util.h>
++#include <libpurple/debug.h>
++#include <libpurple/util.h>
+
+ #include <time.h>
+ #include <sys/types.h>
+--- a/keys.h
++++ b/keys.h
+@@ -20,8 +20,8 @@
+
+ #include "cryptproto.h"
+
+-#include "debug.h"
+-#include "conversation.h"
++#include <libpurple/debug.h>
++#include <libpurple/conversation.h>
+
+
+ #define KEY_DIGEST_LENGTH 10
+--- a/keys_ui.c
++++ b/keys_ui.c
+@@ -21,10 +21,10 @@
+ #include <gtk/gtk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <debug.h>
+-#include <prefs.h>
+-#include <gtkdialogs.h>
+-#include <sound.h>
++#include <libpurple/debug.h>
++#include <libpurple/prefs.h>
++#include <pidgin/gtkdialogs.h>
++#include <libpurple/sound.h>
+
+ #include "encrypt.h"
+ #include "keys.h"
+--- a/nonce.c
++++ b/nonce.c
+@@ -17,12 +17,12 @@
+
+ #include "internal.h"
+
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+
+-#include "debug.h"
++#include <libpurple/debug.h>
+
+-#include "base64.h"
+-#include "pk11func.h"
++#include <nss/base64.h>
++#include <nss/pk11func.h>
+
+ #include "nonce.h"
+
+--- a/nonce.h
++++ b/nonce.h
+@@ -18,7 +18,7 @@
+ #ifndef NONCE_H
+ #define NONCE_H
+
+-#include "glib.h"
++#include "glib-2.0/glib.h"
+
+ typedef unsigned char Nonce[24];
+
+--- a/nss_mgf1.c
++++ b/nss_mgf1.c
+@@ -18,10 +18,10 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#include <pk11func.h>
++#include <nss/pk11func.h>
+
+ /* for g_assert; PORT_Assert seems disabled... */
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+
+ #include "nss_mgf1.h"
+
+--- a/nss_oaep.c
++++ b/nss_oaep.c
+@@ -19,11 +19,11 @@
+ *
+ */
+
+-#include <pk11func.h>
+-#include <keyhi.h>
++#include <nss/pk11func.h>
++#include <nss/keyhi.h>
+
+ /* for g_assert; PORT_Assert seems disabled... */
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+
+ #include "nss_mgf1.h"
+ #include "nss_oaep.h"
+--- a/nss_pss.c
++++ b/nss_pss.c
+@@ -19,12 +19,12 @@
+ *
+ */
+
+-#include "pk11func.h"
+-#include "keyhi.h"
++#include <nss/pk11func.h>
++#include <nss/keyhi.h>
+
+ /* for g_assert; PORT_Assert seems disabled... */
+-#include <glib.h>
+-#include <debug.h>
++#include <glib-2.0/glib.h>
++#include <libpurple/debug.h>
+
+ #include "nss_mgf1.h"
+ #include "nss_pss.h"
+--- a/pe_blist.c
++++ b/pe_blist.c
+@@ -1,8 +1,8 @@
+ #include "internal.h" // #defines needed for Gaim headers
+
+-#include <blist.h>
+-#include <debug.h>
+-#include <gtkutils.h>
++#include <libpurple/blist.h>
++#include <libpurple/debug.h>
++#include <pidgin/gtkutils.h>
+
+ #include "pe_blist.h"
+ #include "state.h"
+--- a/pe_blist.h
++++ b/pe_blist.h
+@@ -4,8 +4,8 @@
+ #include <gdk/gdk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <gtkplugin.h>
+-#include <blist.h>
++#include <pidgin/gtkplugin.h>
++#include <libpurple/blist.h>
+
+ #include "pidgin-encryption-config.h"
+
+--- a/prefs.c
++++ b/prefs.c
+@@ -21,9 +21,9 @@
+ #include <string.h>
+ #include <unistd.h>
+
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+ #if GLIB_CHECK_VERSION(2,6,0)
+-# include <glib/gstdio.h>
++# include <glib-2.0/glib/gstdio.h>
+ #else
+ # define g_freopen freopen
+ # define g_fopen fopen
+@@ -41,8 +41,8 @@
+ #include <gtk/gtk.h>
+ #include <gtk/gtkplug.h>
+
+-#include "prefs.h"
+-#include "util.h"
++#include <libpurple/prefs.h>
++#include <libpurple/util.h>
+ #include "prefs.h"
+ #include "config_ui.h"
+ #include "keys.h"
+--- a/prefs.h
++++ b/prefs.h
+@@ -19,9 +19,9 @@
+ #ifndef PREFS_H
+ #define PREFS_H
+
+-#include <debug.h>
+-#include <gtkdialogs.h>
+-#include <prefs.h>
++#include <libpurple/debug.h>
++#include <pidgin/gtkdialogs.h>
++#include <libpurple/prefs.h>
+
+ void PE_prefs_changed_cb(const char* name, PurplePrefType type, gconstpointer val, gpointer data);
+
+--- a/rsa_nss.c
++++ b/rsa_nss.c
+@@ -21,10 +21,10 @@
+ #include <gtk/gtk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <debug.h>
+-#include <gtkdialogs.h>
++#include <libpurple/debug.h>
++#include <pidgin/gtkdialogs.h>
+
+-#include <glib.h>
++#include <glib-2.0/glib.h>
+
+ #include <string.h>
+ #include <assert.h>
+@@ -35,13 +35,13 @@
+
+ #include "rsa_nss.h"
+
+-#include <nspr.h>
+-#include <nss.h>
+-#include <ssl.h>
+-#include <secmod.h>
+-#include <pk11func.h>
+-#include <keyhi.h>
+-#include <nssb64.h>
++#include <nspr/nspr.h>
++#include <nss/nss.h>
++#include <nss/ssl.h>
++#include <nss/secmod.h>
++#include <nss/pk11func.h>
++#include <nss/keyhi.h>
++#include <nss/nssb64.h>
+
+
+ #include "nls.h"
+--- a/rsa_nss.h
++++ b/rsa_nss.h
+@@ -29,8 +29,8 @@
+ #undef HAVE_LONG_LONG
+ #endif
+ /* From NSS libraries: */
+-#include <nss.h>
+-#include <keyhi.h>
++#include <nss/nss.h>
++#include <nss/keyhi.h>
+
+ typedef struct {
+ SECKEYPrivateKey* priv;
+--- a/state.c
++++ b/state.c
+@@ -6,11 +6,11 @@
+ #include <gdk/gdk.h>
+ #include <gtk/gtkplug.h>
+
+-#include <gtkplugin.h>
++#include <pidgin/gtkplugin.h>
+
+-#include <debug.h>
+-#include <util.h>
+-#include <conversation.h>
++#include <libpurple/debug.h>
++#include <libpurple/util.h>
++#include <libpurple/conversation.h>
+
+ #include "pe_blist.h"
+ #include "state_ui.h"
+--- a/state_ui.c
++++ b/state_ui.c
+@@ -7,11 +7,11 @@
+ #include <gtk/gtkplug.h>
+ #include <gtk/gtkimagemenuitem.h>
+
+-#include <gtkplugin.h>
+-#include <gtkmenutray.h>
+-#include <debug.h>
+-#include <gtkimhtml.h>
+-#include <gtklog.h>
++#include <pidgin/gtkplugin.h>
++#include <pidgin/gtkmenutray.h>
++#include <libpurple/debug.h>
++#include <pidgin/gtkimhtml.h>
++#include <pidgin/gtklog.h>
+
+ #include "state_ui.h"
+ #include "state.h"
+--- a/state_ui.h
++++ b/state_ui.h
+@@ -7,13 +7,13 @@
+ #include <gdk/gdk.h>
+ #include <gtk/gtkplug.h>
+
+-#include "gtkplugin.h"
++#include <pidgin/gtkplugin.h>
+
+-#include <gtkdialogs.h>
+-#include <log.h>
+-#include <gtkconv.h>
+-#include <gtklog.h>
+-#include <gtkutils.h>
++#include <pidgin/gtkdialogs.h>
++#include <libpurple/log.h>
++#include <pidgin/gtkconv.h>
++#include <pidgin/gtklog.h>
++#include <pidgin/gtkutils.h>
+
+ void PE_state_ui_init();
+ void PE_state_ui_delete();
diff --git a/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-time.patch b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-time.patch
new file mode 100644
index 000000000000..ba14857dcb03
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.1-time.patch
@@ -0,0 +1,135 @@
+Patch by ironmikkl, posted in bugs.gentoo.org
+
+Bug: https://bugs.gentoo.org/887623
+Bug: https://bugs.gentoo.org/940497
+
+--- a/encrypt.c
++++ b/encrypt.c
+@@ -212,7 +212,7 @@
+ purple_conversation_write(conv, 0,
+ _("This account key is too large for this protocol. "
+ "Unable to send."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ return;
+ }
+
+@@ -326,7 +326,7 @@
+ newnode->who[sizeof(newnode->who)-1] = 0;
+
+ newnode->gc = gc;
+- newnode->time = time((time_t)NULL);
++ newnode->time = time((time_t)0);
+ strcpy(newnode->msg, msg);
+ newnode->next = 0;
+
+@@ -443,7 +443,7 @@
+ }
+
+ purple_conv_im_write(PURPLE_CONV_IM(conv), NULL, tmp_msg,
+- PURPLE_MESSAGE_RECV, time((time_t)NULL));
++ PURPLE_MESSAGE_RECV, time((time_t)0));
+
+ g_free(tmp_msg);
+
+@@ -670,7 +670,7 @@
+ purple_debug(PURPLE_DEBUG_MISC, "pidgin-encryption", "Got key in response to error\n");
+ purple_conversation_write(conv, 0,
+ _("Last outgoing message not received properly- resetting"),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+
+ PE_received_key(headerpos + header_size + sizeof(": ErrKey") - 1, name, acct,
+ conv, message);
+@@ -755,7 +755,7 @@
+ if (conv != 0) {
+ purple_conversation_write(conv, 0,
+ _("Received message encrypted with wrong key"),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+
+ } else {
+ purple_debug(PURPLE_DEBUG_WARNING, "pidgin-encryption",
+@@ -792,7 +792,7 @@
+ if (conv != 0) {
+ purple_conversation_write(conv, 0,
+ _("Error in decryption- asking for resend..."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+
+ } else {
+ purple_debug(PURPLE_DEBUG_WARNING, "pidgin-encryption",
+@@ -939,7 +939,7 @@
+
+ purple_debug(PURPLE_DEBUG_INFO, "pidgin-encryption", "requesting key\n");
+ purple_conversation_write(conv, 0, _("Requesting key..."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+
+ PE_store_msg(who, acct->gc, *message, &first_out_msg, &last_out_msg);
+
+@@ -976,7 +976,7 @@
+ purple_debug(PURPLE_DEBUG_INFO, "pidgin-encryption", "im_write: %s\n", dupname);
+
+ purple_conv_im_write(PURPLE_CONV_IM(conv), NULL, disp_msg,
+- PURPLE_MESSAGE_SEND, time((time_t)NULL));
++ PURPLE_MESSAGE_SEND, time((time_t)0));
+ g_free(disp_msg);
+
+ /* Add message to stash of sent messages: in case a key or nonce is wrong, we */
+@@ -1073,7 +1073,7 @@
+ if (his_key == 0) { /* Don't have key for this guy */
+ purple_conversation_write(conv, 0,
+ _("No key to resend message. Message lost."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+
+ } else { /* We have a key. Encrypt and send. */
+
+@@ -1114,7 +1114,7 @@
+ footer);
+ purple_conversation_write(conv, 0,
+ "Resending...",
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ serv_send_im(conv->account->gc, name, out_msg, 0);
+
+ purple_debug(PURPLE_DEBUG_INFO, "pidgin-encryption",
+@@ -1126,7 +1126,7 @@
+ g_free(crypt_msg);
+ } else {
+ purple_conversation_write(conv, 0, _("Outgoing message lost."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ }
+ }
+ }
+--- a/keys.c
++++ b/keys.c
+@@ -96,7 +96,7 @@
+ if (conv != 0) {
+ purple_conversation_write(conv, "Encryption Manager",
+ _("Making new key pair..."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ }
+
+ PE_make_private_pair((crypt_proto *)crypt_proto_list->data, name, conv->account, 1024);
+@@ -113,7 +113,7 @@
+ if (conv != 0) {
+ purple_conversation_write(conv, "Encryption Manager",
+ _("Error trying to make key."),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ }
+
+ return 0;
+@@ -278,7 +278,7 @@
+ case KEY_CONFLICT:
+ if (conv) {
+ purple_conversation_write(conv, "Encryption Manager", _("Conflicting Key Received!"),
+- PURPLE_MESSAGE_SYSTEM, time((time_t)NULL));
++ PURPLE_MESSAGE_SYSTEM, time((time_t)0));
+ }
+ PE_choose_accept_conflict_key(new_key, resend_msg_id, conv);
+ break;
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r2.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r3.ebuild
index 185f498c3281..19104a15c88d 100644
--- a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r2.ebuild
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic
DESCRIPTION="Pidgin IM Encryption PlugIn"
-HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
+HOMEPAGE="https://pidgin-encrypt.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/pidgin-encrypt/${P}.tar.gz"
LICENSE="GPL-2"
@@ -24,15 +24,19 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-glib2.32.patch"
+ "${FILESDIR}/${P}-time.patch"
+ "${FILESDIR}/${P}-includes.patch"
)
src_configure() {
strip-flags
replace-flags -O? -O2
- econf $(use_enable nls) --disable-static
+ econf $(use_enable nls)
}
src_install() {
emake install DESTDIR="${ED}"
dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+
+ find "${ED}" -type f -name "*.la" -delete || die
}
diff --git a/x11-plugins/pidgin-otr/Manifest b/x11-plugins/pidgin-otr/Manifest
index 7ec4f940dfec..93f663245b6e 100644
--- a/x11-plugins/pidgin-otr/Manifest
+++ b/x11-plugins/pidgin-otr/Manifest
@@ -1,4 +1,5 @@
AUX pidgin-otr-4.0.2-dont-clobber-fortify-source.patch 634 BLAKE2B e40228f111b4314d0363c20b0468f390f559cb63a7fc70581950f292296cab59d584ff4f21ff468c7528a45f6a0443e53663b2a1676e7444f70858b64d2827e9 SHA512 8c473bab713b7f66683d07cf51fcf431bb9bea192e969755dce2dc99501c56dbc4041c3477b3410c762ecc6b5fd10c045bf24e8fbdccacc64947916343c05896
+AUX pidgin-otr-4.0.2-includes.patch 481 BLAKE2B ee04706614a44ad4680c858adec1f9c2bbca68189f75be354cd9b7de8b400f386b8018cd2d617d5ec1dbf2571be1c150a3183da741c53c6e4fe273ce83daee46 SHA512 479c239018568ab237ee01f87d9b5d4afb797c9250d99a9df33856ed50d1abe2d1541e72173d99e8f4f2da9e48d4857aa93c8221f7f36c818c1b449c49d1bba7
DIST pidgin-otr-4.0.2.tar.gz 515627 BLAKE2B e4ee9887d755f27f121c86337df596939eb1ae83ae91d1a396140be27558ee086cca54e2fb7e2337603fc78df00228e8a5759c3adc8b6c68bfdb3f3fa9476163 SHA512 6815f1d2be5786726602a924ae6ead5371543a53bd36231dc3239fa580f73a6136836df0c1beb64d83b76e6bd0d80ffe6750ca6e9ddd2a6a94841a9a678925ad
-EBUILD pidgin-otr-4.0.2-r4.ebuild 852 BLAKE2B ee351d064af8f0678137ed088b5299483dbfa87a6e723e7e6518433d78867414d247ad61c88d7c903db2be902cc3dabccd881ff4d778fca4ac965d68edfe2518 SHA512 fb0f0cab0a4648fb697c91618379853c195baaec5ab0b4ac5845628f043c6eeae4c389dc4e036e42df7c03387cc444a6dfab667f5836849cb5eb7269797bcb95
+EBUILD pidgin-otr-4.0.2-r4.ebuild 894 BLAKE2B b94070e58fcd42d86741465a3b35d8c31e9c4ebc2a6f9d97a0493800c3e21a8d78332ca104924d7a1de919d2669bb4a50ad648013ac2fa13df2df6bf360e7a40 SHA512 96da647ee579e70ac2757d6e4842adaf8682dd365c8a7cd19d0a1e759ce1ade427a7952c03ed026457fca27a418f39a7be346bea346fa30cdae6fbbb0dbe6f53
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-includes.patch b/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-includes.patch
new file mode 100644
index 000000000000..6008fe769c81
--- /dev/null
+++ b/x11-plugins/pidgin-otr/files/pidgin-otr-4.0.2-includes.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/944783
+--- a/otr-plugin.c
++++ b/otr-plugin.c
+@@ -33,12 +33,12 @@
+ #include <gcrypt.h>
+
+ /* purple headers */
+-#include "pidgin.h"
+-#include "notify.h"
+-#include "version.h"
+-#include "util.h"
+-#include "debug.h"
+-#include "core.h"
++#include "pidgin/pidgin.h"
++#include "libpurple/notify.h"
++#include "libpurple/version.h"
++#include "libpurple/util.h"
++#include "libpurple/debug.h"
++#include "libpurple/core.h"
+
+ #ifdef USING_GTK
+ /* purple GTK headers */
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r4.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r4.ebuild
index b7459dd660f8..2542dc365e82 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r4.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-4.0.2-r4.ebuild
@@ -31,6 +31,7 @@ DOCS=( AUTHORS ChangeLog NEWS README )
PATCHES=(
"${FILESDIR}"/${PN}-4.0.2-dont-clobber-fortify-source.patch
+ "${FILESDIR}"/${PN}-4.0.2-includes.patch
)
src_prepare() {