summaryrefslogtreecommitdiff
path: root/x11-plugins/wmweather+/wmweather+-2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmweather+/wmweather+-2.13.ebuild')
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmweather+/wmweather+-2.13.ebuild b/x11-plugins/wmweather+/wmweather+-2.13.ebuild
new file mode 100644
index 000000000000..85d33f4e9385
--- /dev/null
+++ b/x11-plugins/wmweather+/wmweather+-2.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit flag-o-matic
+
+DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
+HOMEPAGE="http://www.sourceforge.net/projects/wmweatherplus/"
+SRC_URI="mirror://sourceforge/wmweatherplus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~mips ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ >=net-misc/curl-7.17.1
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-wm/windowmaker"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ append-flags "-fno-optimize-sibling-calls"
+ econf
+}
+
+src_install() {
+ dobin wmweather+
+ dodoc ChangeLog HINTS README example.conf
+ doman wmweather+.1
+}