summaryrefslogtreecommitdiff
path: root/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmlaptop/wmlaptop-1.4.ebuild')
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
new file mode 100644
index 000000000000..5de91232ce7e
--- /dev/null
+++ b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
+
+DESCRIPTION="Dockapp for laptop users"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/509/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/227"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-ACPI-detection.patch
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
+
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
+
+ domenu "${FILESDIR}/${PN}.desktop"
+}