summaryrefslogtreecommitdiff
path: root/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild')
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
index 131e0beaee7a..b1d7ff43dabc 100644
--- a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
+++ b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,9 +29,12 @@ S=${WORKDIR}/${MY_PN}-${PV}/${MY_PN}
PATCHES=( "${FILESDIR}"/${PN}-noman.patch )
src_prepare() {
- sed -i -e 's/-geom /-geometry /' GrabImage || die "sed failed."
- sed -i -e 's/install -s -m /install -m /' Makefile || die "sed failed."
+ sed -i -e 's/-geom /-geometry /' GrabImage || die
+ sed -i -e 's/install -s -m /install -m /' Makefile || die
default
+
+ pushd "${WORKDIR}"/${MY_PN}-${PV} || die
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
}
src_compile() {