summaryrefslogtreecommitdiff
path: root/x11-plugins/wmbattery/wmbattery-2.44.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmbattery/wmbattery-2.44.ebuild')
-rw-r--r--x11-plugins/wmbattery/wmbattery-2.44.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmbattery/wmbattery-2.44.ebuild b/x11-plugins/wmbattery/wmbattery-2.44.ebuild
new file mode 100644
index 000000000000..d9be4bb33db2
--- /dev/null
+++ b/x11-plugins/wmbattery/wmbattery-2.44.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools
+
+DESCRIPTION="A dockable app to report APM, ACPI, or SPIC battery status"
+HOMEPAGE="http://joeyh.name/code/wmbattery/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc -sparc x86"
+IUSE="upower"
+
+RDEPEND="sys-apps/apmd
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README TODO debian/changelog )
+
+src_prepare() {
+ sed -i \
+ -e '/^icondir/s:icons:pixmaps:' \
+ autoconf/makeinfo.in || die
+
+ use upower || { sed -i -e 's:USE_UPOWER = 1:#&:' autoconf/makeinfo.in || die; }
+
+ eautoconf
+}