summaryrefslogtreecommitdiff
path: root/x11-plugins/wmSMPmon
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmSMPmon')
-rw-r--r--x11-plugins/wmSMPmon/Manifest3
-rw-r--r--x11-plugins/wmSMPmon/files/wmSMPmon-3.1-fno-common.patch36
-rw-r--r--x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild11
3 files changed, 47 insertions, 3 deletions
diff --git a/x11-plugins/wmSMPmon/Manifest b/x11-plugins/wmSMPmon/Manifest
index f1ca3925b967..5f34dedb0646 100644
--- a/x11-plugins/wmSMPmon/Manifest
+++ b/x11-plugins/wmSMPmon/Manifest
@@ -1,4 +1,5 @@
+AUX wmSMPmon-3.1-fno-common.patch 1474 BLAKE2B d4b8939e22d5c077fc4e7ac26edf3c963e04e5f938e582984e021c00cdb27c58567ec88db7096379ac844cfdc5d2afb894ce28b08a421876dd8428ac35813fff SHA512 e9eb96ed543e39df41270b476a00d0e9ba3dfcd1faef81728a4dd07578bf76999db43e68049354f421f9ecc138c8fa81ccbacc0bb75053879c0db6759b5575c6
AUX wmSMPmon-3.1-makefile.patch 1300 BLAKE2B d017661312fe29484eaeffe05a5f8cbacd54c19c3ebc9f52ca6605704427292b23ec695b9403360aaec0d48c61453cf69d4e269f777cbffd8b194a3d078150bc SHA512 e94f9a66d782aaaab3bd637c2657cd34efe1b5e1f556c932171e30814551236f67a1846b688bda8983a072ba1622d37f8aa14528c657e9542404fa8b96358826
DIST wmSMPmon-3.1.tar.gz 24834 BLAKE2B c02c49810f69b9d28d42f24e7fde6556d46f214d4cb5b47cd705bed2ff5c2c00205829018179ecd6c63162a58d0a957d5fa35d33f0075532c72d3d6876ac6c40 SHA512 b13caa3c4bc7971d35bc52bb66c1f6da482b55a5073b61b3f059fac97f6affbf091816c933981c1c88c17127ab8d21c09c59d0f3c93364e659ca409f13de43b7
-EBUILD wmSMPmon-3.1-r2.ebuild 606 BLAKE2B cb23f1aa1c267ed95ad3387aab7a4df80c3d19dabf92d29c2466b72a58874723027527db5c2f26b0480b99d37eee45e7f4fd58d1f3d1ed54122d02cae4ec51dc SHA512 9258edec15c7ad331f3fb13d9c6fa7db32c0e6f374a7c219dc20fbc9fb24bda8b0f418a93b7e4d0c1491b056a761e8f8140dde473ff5eb4d80e4cdb7ac52de99
+EBUILD wmSMPmon-3.1-r2.ebuild 709 BLAKE2B 1df19b9a8ac95ab65a6325df976761366853d06065c94d68700c741b8050abdaaea7e5908510387cc704c9571b5b7e9e65363d27eaeec77b5f2f0bdc74689ca8 SHA512 8ac821d8ebe30e47ebc94328f7a16690bef18cf48a3ec283191897b9eb6205a75afdd16ad3cc734c3e3060841abb788857305eab64b454d94afe1ff80b9c5fd9
MISC metadata.xml 379 BLAKE2B 8d029b244f6cba1311fc8af0fa96705ad2701ffe2d4aad6a45e3e86d6a7b07c1749f7ffdd171217c5f610681921006400f6641618a6cf93541e7b257f2441198 SHA512 2fc60cceb3fbdbbb8fd85048bc50b6777461a9c7cf37d8b672ac09d1556f284acfa5df747d704c9335bfe91f93142be1cf39cd4eb19c808a50eb8fe5a27f67d5
diff --git a/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-fno-common.patch b/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-fno-common.patch
new file mode 100644
index 000000000000..f1416fcc0248
--- /dev/null
+++ b/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-fno-common.patch
@@ -0,0 +1,36 @@
+diff -Naur wmSMPmon-3.1.orig/wmgeneral/wmgeneral.h wmSMPmon-3.1/wmgeneral/wmgeneral.h
+--- wmSMPmon-3.1.orig/wmgeneral/wmgeneral.h 1999-04-25 05:08:22.000000000 +0200
++++ wmSMPmon-3.1/wmgeneral/wmgeneral.h 2020-03-29 13:32:55.253627166 +0200
+@@ -36,7 +36,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wmSMPmon-3.1.orig/wmSMPmon/standards.h wmSMPmon-3.1/wmSMPmon/standards.h
+--- wmSMPmon-3.1.orig/wmSMPmon/standards.h 2004-11-19 14:57:30.000000000 +0100
++++ wmSMPmon-3.1/wmSMPmon/standards.h 2020-03-29 13:32:14.666639432 +0200
+@@ -37,7 +37,7 @@
+ #define HAUTEUR 31 /* Max. height of CPU Load Bar+Graph */
+
+ /* Program name used in error messages */
+-char *Myname;
++extern char *Myname;
+
+ /* NumCPUs_DoInit returns the number of CPUs present in the system and
+ performs any initialization necessary for the sysinfo-XXX module */
+diff -Naur wmSMPmon-3.1.orig/wmSMPmon/wmSMPmon.c wmSMPmon-3.1/wmSMPmon/wmSMPmon.c
+--- wmSMPmon-3.1.orig/wmSMPmon/wmSMPmon.c 2005-11-07 01:24:32.000000000 +0100
++++ wmSMPmon-3.1/wmSMPmon/wmSMPmon.c 2020-03-29 13:33:03.630624637 +0200
+@@ -35,6 +35,8 @@
+ /*###### Funcition definitions ##########################################*/
+ void usage(int cpus, const char *str);
+
++char *Myname;
++Display *display;
+
+ /*###### MAIN PROGRAM ###################################################*/
+ int main(int argc, char **argv)
diff --git a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
index 9619fe673e8c..cc153566aa1a 100644
--- a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
+++ b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,10 +22,17 @@ DEPEND="${RDEPEND}
DOCS=( ../Changelog )
-S="${WORKDIR}/${P}/${PN}"
+S=${WORKDIR}/${P}/${PN}
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
+}
+
src_compile() {
emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
}