summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-privacy-please
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-privacy-please')
-rw-r--r--x11-plugins/pidgin-privacy-please/Manifest3
-rw-r--r--x11-plugins/pidgin-privacy-please/metadata.xml5
-rw-r--r--x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild31
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-plugins/pidgin-privacy-please/Manifest b/x11-plugins/pidgin-privacy-please/Manifest
index 97638df8fd6e..d2b6c2bd66e8 100644
--- a/x11-plugins/pidgin-privacy-please/Manifest
+++ b/x11-plugins/pidgin-privacy-please/Manifest
@@ -1,3 +1,4 @@
DIST pidgin-privacy-please-0.7.1.tar.gz 346421 BLAKE2B 051dca780d11eb6c8e4fed65a0dc6d660185f6210fd5c76021dd80bfa89894ee3dfbc829344498f87b8af25dd048d19bcaa4070f669b723a9374fe62685b8acd SHA512 4acec4556c209b6ff5b059244d79894efba984cdebaaf5893c67ba384126127614aea676af6deb89561f6d5776abdbdc915061db9e1004c0fea3339d45a6646a
+EBUILD pidgin-privacy-please-0.7.1-r1.ebuild 651 BLAKE2B cec001651d8816a97272ab6ec50d29b5bf4158c8939d00177f91fbc0b801d1037e5f1deb948def8457c52e3706c39d9336845301e35e3f292a661ade33c4ee19 SHA512 cb0fea41f97c2b06c1e6e129e8c3d4b5c9c74c88b4b3e5a2deb527fd19f7f443a77b165e1422f8c8ea4b7fc8665991839c730bc51ae40af34b8feffd76a43b2f
EBUILD pidgin-privacy-please-0.7.1.ebuild 542 BLAKE2B b2aecdb7737306365412a8a892a03365296cb4a966b2fd858b895e9975fe2da5d15e7a3265cf30a1cbe0fa43f8c46c73ecf51cbeba3cb0113f0f234efd726923 SHA512 2d9da19ea1716d7c9595921e7aee0d09d5e414ceaa56aa24104c51a4e02d6284735a121c20fe69072e8e99ea61b58255d2031d8ecce5540d6423f17e74917c06
-MISC metadata.xml 259 BLAKE2B 4e3d02bae5ec4083ed6e394434a5d0a973c4c0c62b234924d04c38977a7be2975d5b003fa861402cd0c098ff247ebb16166cacf531fc218977fe4b72f02dc16f SHA512 bb0956dbaf1c37a314b6a15b06cd0800d80b68ce2726b9cce937c854a7aa452063c9585d06b8491a0e73a051ca71e383b93c0416d5bb3a4481a7e012493cab86
+MISC metadata.xml 344 BLAKE2B b55d77f6553548fcced3a5489d1bb4ba6ddfae6f673ba5cd31cede7621ca45bbde112c9888b72a2844a8fbc93dc836a23688bfa1e8997c6ce6755b25cfd21b57 SHA512 3c16b42076043df6a66ea718b7d081eb8bbdbeb6abb581e52fbe8832c5196c3c058418ed4e32179625a2afc6bdae64d40e75ef473583e51324ed0c6d053fc680
diff --git a/x11-plugins/pidgin-privacy-please/metadata.xml b/x11-plugins/pidgin-privacy-please/metadata.xml
index c3c97dea8658..11298de835d5 100644
--- a/x11-plugins/pidgin-privacy-please/metadata.xml
+++ b/x11-plugins/pidgin-privacy-please/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>nativemad@gentoo.org</email>
+ <name>Andreas Schuerch</name>
+ </maintainer>
<upstream>
<remote-id type="google-code">pidgin-privacy-please</remote-id>
</upstream>
diff --git a/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..8c2af2004dc2
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Pidgin plugin to stop spammers from annoying you"
+HOMEPAGE="https://code.google.com/p/pidgin-privacy-please/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="<net-im/pidgin-3[gtk]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ sed -e 's: -Wall -g3::' -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+}