summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild
new file mode 100644
index 000000000000..a06fa4d4fd66
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A GKrellM2 plugin to control a fli4l router"
+HOMEPAGE="http://gkrellm-imonc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-src-${PV}"
+
+# The COPYING file contains the GPLv2, but the file headers say GPLv2+.
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-makefile.patch
+ "${FILESDIR}"/${P}-r2-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}