summaryrefslogtreecommitdiff
path: root/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/e16-epplets/e16-epplets-0.17.ebuild')
-rw-r--r--x11-plugins/e16-epplets/e16-epplets-0.17.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild b/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
new file mode 100644
index 000000000000..a9d646dbd7f3
--- /dev/null
+++ b/x11-plugins/e16-epplets/e16-epplets-0.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Enlightenment DR16 epplets"
+HOMEPAGE="https://www.enlightenment.org https://sourceforge.net/projects/enlightenment/"
+SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2+ BSD public-domain"
+SLOT="0"
+IUSE="cdaudio libgtop opengl"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ cdaudio? ( media-libs/libcdaudio )
+ libgtop? ( gnome-base/libgtop )
+ opengl? ( media-libs/glu media-libs/mesa[X(+)] )
+ >=media-libs/imlib2-1.2.0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-wm/e16
+"
+RDEPEND="${CDEPEND}
+ !x11-plugins/epplets
+"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable cdaudio)
+ $(use_enable opengl glx)
+ $(use_with libgtop)
+ --disable-esd
+ --disable-static
+ --disable-werror
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete || die
+}