summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46488 -> 46483 bytes
-rw-r--r--x11-misc/rofi/Manifest2
-rw-r--r--x11-misc/rofi/rofi-1.7.7.ebuild80
3 files changed, 82 insertions, 0 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 596d21e1a0e3..47e61cfb4f85 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 653bcbf2bea9..6130f923ca0b 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,6 +1,8 @@
DIST rofi-1.7.5.tar.xz 772952 BLAKE2B 54511f4f793f3ba0b58294daa1d2974228904a637d13d729b0b7d974c0ebf8d0d98514705212bd42500fe90b0685a3515dc67793baa95baefe6dfc0ecdee83c7 SHA512 84cbb8ccef14fdb5d68062b17245fbcb0e9bab46534eb6c7ce532750b86fb33ce6e43ed24cf3c65e553d15b23a201c9168d97d257da4dddeddb0a7c44dd59cc0
DIST rofi-1.7.6.tar.xz 812496 BLAKE2B 18728bde962a1082927c87c19e00356206632430975f8718f2d961966047026a2cb1266ed868f4510fbe127e7f3e3cae1308a9da69fe46609f78dbc0e8394d2f SHA512 9e2d39abd3dbd7703646e6c0f16383da8f1ec26b911817f574f388cd019c9440fca26100d2de14883c30e74f6c1c451722777dbeee1d2551fc64d78d60fa3023
+DIST rofi-1.7.7.tar.xz 812568 BLAKE2B b5b341d13f2d8609994e9b138722ce6af3896394b60a6734e90ac50cd7921704dcacd3fcbdbc3c1ce4632df1995f7abc1c6399371a483721424181bb9a7b9a69 SHA512 8286bc5f33ab4eb93677b24815730f159347a1e545ff109784fe161eeb4500c4fd4307c7894adb2060d6bef5137c9d6506a71c565e2676be230e5ad740bed9d0
EBUILD rofi-1.7.5.ebuild 1558 BLAKE2B ff5a43973cd4845549d1d3a04169ec3fce8bbc59cfbc88e253a5d2521eca24dd2d33042ac83aa05b350e55ffa5f82eddb11d35c0b05756da64cafe4511879132 SHA512 ca99b90495799a1ba5f5191fd75f1e4fdb87ca411b1169cfe0705a1da43aed2c011708f6f73209391601909198960a7b280e8b4ede8c6b0d51a10260e89d13d2
EBUILD rofi-1.7.6-r2.ebuild 1474 BLAKE2B 29b7d8fede475169d7029eb6121242b62ed109602f98c3f11e500a5a888592a410cda20798ef20e51c630b5e8321941bb9775dd1aa6ef15941e9650cc6c6e7f2 SHA512 711beb3f5ed8c686dbddc7ea338da3ef43510768068d8e3f2605da0d9420018aa1f6a016f849ff8bf80139cbf738880f7bf4f0d83fb6343b71e681d8a4f88548
+EBUILD rofi-1.7.7.ebuild 1474 BLAKE2B 29b7d8fede475169d7029eb6121242b62ed109602f98c3f11e500a5a888592a410cda20798ef20e51c630b5e8321941bb9775dd1aa6ef15941e9650cc6c6e7f2 SHA512 711beb3f5ed8c686dbddc7ea338da3ef43510768068d8e3f2605da0d9420018aa1f6a016f849ff8bf80139cbf738880f7bf4f0d83fb6343b71e681d8a4f88548
EBUILD rofi-9999.ebuild 1474 BLAKE2B 29b7d8fede475169d7029eb6121242b62ed109602f98c3f11e500a5a888592a410cda20798ef20e51c630b5e8321941bb9775dd1aa6ef15941e9650cc6c6e7f2 SHA512 711beb3f5ed8c686dbddc7ea338da3ef43510768068d8e3f2605da0d9420018aa1f6a016f849ff8bf80139cbf738880f7bf4f0d83fb6343b71e681d8a4f88548
MISC metadata.xml 459 BLAKE2B c216cf3a381b704ada1783b5fd2d1b090f4ea784cc56e336de82707bc878adac541be2fec5a7a2ec1d550e8846d3afaa36cd4451f0a82388dcec32f0bc74f9e9 SHA512 4b47bc066b2fb94e9313279099cf655091f303f9bd78a668754a3c08749a3aa33b2c1a9e827bb97a62a0b99a22295fbae7cb3b800138b6766e8da75c53ee4091
diff --git a/x11-misc/rofi/rofi-1.7.7.ebuild b/x11-misc/rofi/rofi-1.7.7.ebuild
new file mode 100644
index 000000000000..99c15ca7964b
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs xdg-utils
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/bison
+ >=sys-devel/flex-2.5.39
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb:=
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-wm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xcb-util-keysyms
+ test? ( >=dev-libs/check-0.11 )
+"
+
+DOCS=(
+ AUTHORS
+ Changelog
+ Examples/
+ README.md
+)
+
+src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
+ tc-export CC
+
+ local emesonargs=(
+ $(meson_use drun)
+ $(meson_use windowmode window)
+ $(meson_feature test check)
+ -Dimdkit=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}