summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46513 -> 46513 bytes
-rw-r--r--x11-misc/mate-notification-daemon/Manifest4
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild63
-rw-r--r--x11-misc/mate-notification-daemon/metadata.xml9
-rw-r--r--x11-misc/spacefm/Manifest2
-rw-r--r--x11-misc/spacefm/spacefm-1.0.6-r4.ebuild (renamed from x11-misc/spacefm/spacefm-1.0.6-r3.ebuild)2
-rw-r--r--x11-misc/xkeyboard-config/Manifest4
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.43.ebuild66
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild2
9 files changed, 146 insertions, 6 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 3bd5af97b770..700d03419de7 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index c8fe647c75e6..f52bdad23c14 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,4 +1,6 @@
AUX org.freedesktop.Notifications.service 94 BLAKE2B 1a97aac2db9c803c9e4babf9067283b564a1eecb1d251aee3a5e66b8a4f63d2554e3e09ea06749383ce3d5b8e77c8cc3bd87ae2dde48ae8feb4886ecaf7a3c27 SHA512 0575cbfc094455c0a2f04faa534a5e0d9cc41e6d9566ab9bcb0fcbce99e142213ded786ad00c36dc434ae1b9208d34d234a341dfc86adb72925dad0ee2b25f97
DIST mate-notification-daemon-1.28.0.tar.xz 433572 BLAKE2B 89c386fb7707b87de61e5346ab018227864427d590e2908f0c85b8697d2d19d3528870f701adfa8f9657ea395718724d6398baf325d0b1d68284eb855f16df3f SHA512 dba0989945b81ff0fed5e77ac8ef7c96bf52ee854c9dc0f46549697e0d0537a8ff4a9491839076768443cc62140d1dfbf911aee489ab568c2975b67c52c78d2e
+DIST mate-notification-daemon-1.28.1.tar.xz 433384 BLAKE2B 688ef695520eba6e7964acff31303978c99dbfc724d6931ad341c2d3608fccc95bf37893b0445897e67572e52ce2b9372b09c98ba6b1cb3d3bf3bd4648269288 SHA512 72b6b4579d0571638708c5b326cad1b0de8aa2e65b775bf687bf944bca8db74177f018fc105465877f18eeb8ee297350ce8aba74a206a24f3f6c2e42af97ace5
EBUILD mate-notification-daemon-1.28.0.ebuild 1202 BLAKE2B 3eeb4e7e51bcf45328391d4dac333d09b4d29aa92becfee20fb1b4233bd584ee78140b34c24754c3aa9f2a5610ca89ba168f196f5c6c3a031d340eb98581e999 SHA512 29f4ec89fabe31767ea039ba6eb466160b650f99e364dd322d6198bcdf577a5f58126ed3b3039a72400ade72b192cee8a10bd9ac41d6ded7d279134df1eaab8b
-MISC metadata.xml 270 BLAKE2B f0aabf52ce6cd0597d84990d03b9f311d785821c68fbbed96a2a27227c0a0e9e591d76863e1afd153e4ba5b4edfaba3b0b33287085c4d8a4d8b9e471b4ae6db2 SHA512 ea3340fd829238d067e7d59bac716c0e0b4810d820cee869c8e67611ad0e65b05652ed07349b1fad72ef3a008e15dbadb5af76dd0e5e557a0200b5f3fa4cbc20
+EBUILD mate-notification-daemon-1.28.1.ebuild 1205 BLAKE2B fdb9f74fb292f56429668480817b7ae9d9d7572ad789a0c242bcf8a3984788cecdceb43e39b4e01732743614010465b1d2450abea038043044f8d695ded21357 SHA512 919c3e2fef8764a6fc44b30bfb812c466b4aadaa1a8fd8de30b23debd2f99f29388460133b6e34071536fd1069be3ad163bc8beea7a2307f01e6fea932686e1b
+MISC metadata.xml 492 BLAKE2B 813bf0f67b7d6c0c765b3c96a5fbcd09639008df4fc720c11a7472e3d4832a41b144cbf608ade4e522fac34b2c4ddc1db74daa7274853cb75dbd1da14b39d627 SHA512 df124e7affff689090d188be9df708c5519dd6ca1d51e5d61e2e174604600d7ddab08a4f96864d096640e67acefe38af97d5eaa38b85aa78d0603afef437d317
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild
new file mode 100644
index 000000000000..f6253524a304
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE="nls X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND=">=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/gtk+-3.22:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ X? (
+ x11-libs/libX11
+ >=x11-libs/libwnck-3:3
+ )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/notify-osd
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ mate-base/mate-panel
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable nls) \
+ $(use_enable X x11) \
+ $(use_enable wayland)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}
diff --git a/x11-misc/mate-notification-daemon/metadata.xml b/x11-misc/mate-notification-daemon/metadata.xml
index e215d24b5b1b..8b5f9c019d5a 100644
--- a/x11-misc/mate-notification-daemon/metadata.xml
+++ b/x11-misc/mate-notification-daemon/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">mate-desktop/mate-notification-daemon</remote-id>
</upstream>
diff --git a/x11-misc/spacefm/Manifest b/x11-misc/spacefm/Manifest
index 755616249931..3f6ac5c994b4 100644
--- a/x11-misc/spacefm/Manifest
+++ b/x11-misc/spacefm/Manifest
@@ -4,5 +4,5 @@ AUX spacefm-fno-common.patch 2316 BLAKE2B 3f91d4eb0039a3b0e4ba3fe13b9d6436bd91be
AUX spacefm-gcc14-build-fix.patch 3586 BLAKE2B 3e2ff0a26fb927f2dbdd95cd25ba9f38478055f9e77552975fade7f53d359f9cc012c7f30bf38ac98255f2b077c9c4ff2eab38cc8d8082370522f33b18e0c4fe SHA512 042e9868ec850e4764cfdf0108f919b22406dd9bffbd0731dcb6a78759e1b56c0300079cd70e4491e5b1ccce1387bef407f997532c87c4f1dc6949f40db08061
DIST spacefm-1.0.6.tar.gz 3498587 BLAKE2B fc4753ff370fa940ef5737bc7826558847dfbbbec43c1a150d887ed38655f9e45255a737f61a024318c9f37e86a15989da66c83d4dcf5a811603950009b20547 SHA512 37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c
EBUILD spacefm-1.0.6-r2.ebuild 2063 BLAKE2B 58a32c3cb88dcbaeba03503c4473b0f3a20418d0c918a17e9ff61853a6c1c6c9a5cdc915f682a7d33c8789ca66dad6b8d98daa306d816f09f36858f4bbf7f1af SHA512 d287f8aeb038c16b34d6aeefcf2abe3fb6dc1cac1f2ee779d6a4d796b52ca5ebe7b9333d49d2d5a470d80b50a9e15b608c1076b92da0930117be99cc3e6b871b
-EBUILD spacefm-1.0.6-r3.ebuild 2137 BLAKE2B b6b061fe4d5186261c26c124d5cfd7534457c0e8a2442ef3777ef383f8c379f025d34ede365d4c9cdacf5eb95161091c0e95a081821aa26423ad476c0fb9e99d SHA512 1f513803dfd617a6ecd14115f29a8b18d5bcd46e065bec37321105cfb1e1842eb695b346ddbe30dfee1fe29399cf23b5f36f55154d43bb77e38850c647f6fd1e
+EBUILD spacefm-1.0.6-r4.ebuild 2140 BLAKE2B 7da0fe2c305e3bf4fe03c5874623747d25053c4e419c1bd2d5690bcd0832504d284dd9f1d1c1c49fcdc50a91176604be49d216d4bc8d113abe88cf75c564875c SHA512 b638a64cc14015cc1b9b28cebdc5616faeaa469a655ef363d2f217274cb2071285230f417d5b5858fce3e9fd8bfdfad4374e288e8627d0f271c2cadc9e4a152b
MISC metadata.xml 1074 BLAKE2B bb1ae823905cb180e7a65c7c157b97fef75c6839f38f31451876e0697de50ba77a72aed90692fc6df87ede02cd0b2c5e9b7970c01bb2bcf2c598999ea49f2671 SHA512 486c0afcc309a15ed8dff31faa40f8b2f6bfc6d6a6a414661fba7acebbd5e58548e10e5e71185e9ed2ab34f151b7237685428f42b0a48ae8b103fab174b34e88
diff --git a/x11-misc/spacefm/spacefm-1.0.6-r3.ebuild b/x11-misc/spacefm/spacefm-1.0.6-r4.ebuild
index 38b080eb29e4..ee8e3f1236fc 100644
--- a/x11-misc/spacefm/spacefm-1.0.6-r3.ebuild
+++ b/x11-misc/spacefm/spacefm-1.0.6-r4.ebuild
@@ -27,7 +27,7 @@ RDEPEND="dev-libs/glib:2
virtual/freedesktop-icon-theme
x11-libs/cairo
x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
+ x11-libs/gtk+:3[X]
x11-libs/pango
x11-libs/libX11
x11-misc/shared-mime-info
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 9fd75f0a0469..f17c63984198 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1,4 +1,6 @@
DIST xkeyboard-config-2.42.tar.xz 910192 BLAKE2B 1b49a9bdf9e6ad2c196b8c4cc93803a2b4ce804148a7eb55616672db5c4d3eb289e2de931ee8b08a2152dd542a9f2d1e00ba8cca7651d7f33b570ed4a5f4c57b SHA512 654436ae21b9deb3b193847403b652cc5c19aa665a9c9168598fc6ac7af83ac04d40684d9eb99dd4db97c21e5100cfeed06b25e2b041eb9fdf3c05ef95a891a9
+DIST xkeyboard-config-2.43.tar.xz 925424 BLAKE2B 89cf4872305ce3358185ed63f0ff2f0dc90205d50d51b4b881256e0762b12a74f30d0905a75e5feff2f0fef09d94bee778a8cbe83cdf6e048653e8eb42f53087 SHA512 6daf885bf8794cf03d5b447b90ca1666f87e9c609a344e02bb90edca360eb64b24f80a92ed570aa75b4ea62245b3998f6df3757f7e02c4015cdfecee5378a0d4
EBUILD xkeyboard-config-2.42.ebuild 1574 BLAKE2B be170bb0067f1e8a19bce450e8227c671ecd02525c41930a10b951cb696d88ec8b12709bf7687ec3d8f7dab9b18569d6a1cb9dbfb3cfe9a990fe2d915791f56f SHA512 992a19559ca2254bb7e8f4ea0ceeefbd4918d75584f74b87ee45b2add5a19765b768ff27341a4a82576296411ad233e8e7189a37f0a5a6e07b4b2a96174b9424
-EBUILD xkeyboard-config-9999.ebuild 1582 BLAKE2B 9ab1534a11fbea5c5c5b46e63e03000065ed4c58ee1b65eaf7214595e3d5d527425ab4c56215c82bb97a114a7787f1793263a78650f46502c1e5760abb962a36 SHA512 6a83fdbf4604d34f636b0bf9db73836b760037c73c5a39a997b9edf95b0cd9d29e1f25bcd30fdbfcae3cfbabf8d43d17fc43f8b18f3aa8cb87d3b98ea44dfdd5
+EBUILD xkeyboard-config-2.43.ebuild 1582 BLAKE2B beee2bce78e8c6616cc3d8eac2fe050dd1eb243e03a24d3f3102cc00e7b2732afe7da5b54d33c7a5f8eb79a4ad445b6e89e63b12eb2746ab9587b9ae9cc95745 SHA512 0ad649e9dfa09364a57bb8f93a0bad356d3d8ab6c0aa3adf7766c8aa18907e6d43e0ff9990dbfdf7d1e967e8f299d288ea7d1f7cf564fdb206a333a0b3ff7761
+EBUILD xkeyboard-config-9999.ebuild 1582 BLAKE2B beee2bce78e8c6616cc3d8eac2fe050dd1eb243e03a24d3f3102cc00e7b2732afe7da5b54d33c7a5f8eb79a4ad445b6e89e63b12eb2746ab9587b9ae9cc95745 SHA512 0ad649e9dfa09364a57bb8f93a0bad356d3d8ab6c0aa3adf7766c8aa18907e6d43e0ff9990dbfdf7d1e967e8f299d288ea7d1f7cf564fdb206a333a0b3ff7761
MISC metadata.xml 442 BLAKE2B 3e7e6564b3aa17ef958ae6aed94b6d28156d743ad2782b0c2c08429adff128a7a7ea549e2f5fcece91cdc0f498d341790d0694b193dae16b60a63966bbb581b8 SHA512 0c32c580abc07b3141fa3b9137eba130654e0701b4c9e49be10a801c5c068d67881a74dc0e5d45dc34e8964364e0516bbc5e1b854ae0d7d8ff12bf1ec1ec2986
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.43.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.43.ebuild
new file mode 100644
index 000000000000..d4e67dee2a23
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.43.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig/ https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+ ${PYTHON_DEPS}
+ test? (
+ x11-apps/xkbcomp
+ x11-libs/libxkbcommon
+ $(python_gen_any_dep '
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ use test || return 0
+ python_has_version \
+ "dev-python/pycountry[${PYTHON_USEDEP}]" \
+ "dev-python/pytest-xdist[${PYTHON_USEDEP}]" \
+ "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+
+ # Remove pytest timeout
+ sed -i -e "/test('pytest'/,/)$/ { s/timeout: [0-9]*/timeout: 0/ }" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
index 0eeb498babbf..d4e67dee2a23 100644
--- a/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_{11..13} )
inherit meson python-any-r1
DESCRIPTION="X keyboard configuration database"