summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46502 -> 46505 bytes
-rw-r--r--x11-misc/rofi/Manifest4
-rw-r--r--x11-misc/rofi/rofi-1.7.6-r1.ebuild73
-rw-r--r--x11-misc/rofi/rofi-9999.ebuild24
4 files changed, 86 insertions, 15 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index bfb9a56d8d4b..e94ce1e8aa2b 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index dfb656aae9c6..50e3082fcce2 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,4 +1,6 @@
DIST rofi-1.7.5.tar.xz 772952 BLAKE2B 54511f4f793f3ba0b58294daa1d2974228904a637d13d729b0b7d974c0ebf8d0d98514705212bd42500fe90b0685a3515dc67793baa95baefe6dfc0ecdee83c7 SHA512 84cbb8ccef14fdb5d68062b17245fbcb0e9bab46534eb6c7ce532750b86fb33ce6e43ed24cf3c65e553d15b23a201c9168d97d257da4dddeddb0a7c44dd59cc0
+DIST rofi-1.7.6.tar.xz 812496 BLAKE2B 18728bde962a1082927c87c19e00356206632430975f8718f2d961966047026a2cb1266ed868f4510fbe127e7f3e3cae1308a9da69fe46609f78dbc0e8394d2f SHA512 9e2d39abd3dbd7703646e6c0f16383da8f1ec26b911817f574f388cd019c9440fca26100d2de14883c30e74f6c1c451722777dbeee1d2551fc64d78d60fa3023
EBUILD rofi-1.7.5.ebuild 1558 BLAKE2B ff5a43973cd4845549d1d3a04169ec3fce8bbc59cfbc88e253a5d2521eca24dd2d33042ac83aa05b350e55ffa5f82eddb11d35c0b05756da64cafe4511879132 SHA512 ca99b90495799a1ba5f5191fd75f1e4fdb87ca411b1169cfe0705a1da43aed2c011708f6f73209391601909198960a7b280e8b4ede8c6b0d51a10260e89d13d2
-EBUILD rofi-9999.ebuild 1410 BLAKE2B 4ccdf27941fb27c50db39a5f9d9ece0cde3b399524415e1883924fb20bb94e6154192c3de70890e4d446d6ce8f5f5a2d7b85a70eb96d190012e764a01e515b4b SHA512 5728cb65250376a8e1c6bdfc32d7ceb8050e2e46e20dc481da7c90b91b94d74632587e35f88f35daa97eb6a8eaef84fe9333d47338923a359705059afcbfb58b
+EBUILD rofi-1.7.6-r1.ebuild 1422 BLAKE2B b92dcba85e7d8e737acc3693e81983e0866648f858459e0c45e8c7a93711173c84d0867b0e9877b0ad19785058c49217df5307597e915e877ead4672793b3a8c SHA512 76c0d738cdf5450c94b94fbd49aca51ddf75b2f016bd45bc6ba92d5f99d4f35bf61a7b26cc6efc49d53ce8ad12afcfff08c99c864e1cea0e3ba1c56232f0b288
+EBUILD rofi-9999.ebuild 1395 BLAKE2B 338288373cf9273a76230c755fe01f366a57c2d59d0261ad5ad9d64a60d40461fe4a4dad6f101c58b10b65306e893c500c89c5e28d8fb6235d5d829693b4e935 SHA512 a29691f49583f81e3965f561882763473f901e3cd492d4c9e74a76128135b1da0cf016c147a3ee5cdc44ebac27da3e21ee6f9b731862e138fb7845e3a62f3c2f
MISC metadata.xml 459 BLAKE2B c216cf3a381b704ada1783b5fd2d1b090f4ea784cc56e336de82707bc878adac541be2fec5a7a2ec1d550e8846d3afaa36cd4451f0a82388dcec32f0bc74f9e9 SHA512 4b47bc066b2fb94e9313279099cf655091f303f9bd78a668754a3c08749a3aa33b2c1a9e827bb97a62a0b99a22295fbae7cb3b800138b6766e8da75c53ee4091
diff --git a/x11-misc/rofi/rofi-1.7.6-r1.ebuild b/x11-misc/rofi/rofi-1.7.6-r1.ebuild
new file mode 100644
index 000000000000..49bd72583a8e
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.6-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs xdg-utils
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/davatorium/rofi"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/bison
+ >=sys-devel/flex-2.5.39
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libxcb:=
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_configure() {
+ # Doesn't work with reflex, bug #887049
+ export LEX=flex
+
+ # Requires bison, see https://bugs.gentoo.org/894634.
+ unset YACC
+
+ tc-export CC
+
+ local emesonargs=(
+ $(meson_use drun)
+ $(meson_use windowmode window)
+ $(meson_feature test check)
+ -Dimdkit=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-misc/rofi/rofi-9999.ebuild b/x11-misc/rofi/rofi-9999.ebuild
index aa90b0c02f84..d1d57fe871c1 100644
--- a/x11-misc/rofi/rofi-9999.ebuild
+++ b/x11-misc/rofi/rofi-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs xdg-utils
+inherit meson toolchain-funcs xdg-utils
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
HOMEPAGE="https://github.com/davatorium/rofi"
@@ -13,7 +13,7 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
else
SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 arm64 ~riscv x86"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
fi
LICENSE="MIT"
@@ -27,7 +27,7 @@ BDEPEND="
virtual/pkgconfig
"
RDEPEND="
- dev-libs/glib:2
+ >=dev-libs/glib-2.72:2
x11-libs/cairo[X,xcb(+)]
x11-libs/gdk-pixbuf:2
x11-libs/libxcb:=
@@ -45,11 +45,6 @@ DEPEND="
test? ( >=dev-libs/check-0.11 )
"
-src_prepare() {
- default
- eautoreconf
-}
-
src_configure() {
# Doesn't work with reflex, bug #887049
export LEX=flex
@@ -59,12 +54,13 @@ src_configure() {
tc-export CC
- local myeconfargs=(
- $(use_enable drun)
- $(use_enable test check)
- $(use_enable windowmode)
+ local emesonargs=(
+ $(meson_use drun)
+ $(meson_use windowmode window)
+ $(meson_feature test check)
+ -Dimdkit=false
)
- econf "${myeconfargs[@]}"
+ meson_src_configure
}
pkg_postinst() {