summaryrefslogtreecommitdiff
path: root/x11-misc/xsr/xsr-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsr/xsr-1.0.0-r1.ebuild')
-rw-r--r--x11-misc/xsr/xsr-1.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/xsr/xsr-1.0.0-r1.ebuild b/x11-misc/xsr/xsr-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d7271865771b
--- /dev/null
+++ b/x11-misc/xsr/xsr-1.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="X Steps Recorder"
+HOMEPAGE="https://github.com/nonnymoose/xsr"
+SRC_URI="https://github.com/nonnymoose/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cursor"
+
+RDEPEND="
+ dev-lang/perl
+ media-gfx/scrot
+ cursor? (
+ media-gfx/imagemagick
+ x11-misc/xdotool
+ )"
+
+src_install() {
+ dobin xsr
+
+ insinto /usr/share/xsr
+ doins Cursor.png
+
+ einstalldocs
+}