summaryrefslogtreecommitdiff
path: root/x11-misc/xrootconsole/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xrootconsole/files')
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch36
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch22
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch52
3 files changed, 110 insertions, 0 deletions
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
new file mode 100644
index 000000000000..4b3aee406733
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
@@ -0,0 +1,36 @@
+--- a/Makefile.org 2004-02-20 22:53:28.000000000 +0100
++++ b/Makefile 2010-02-08 12:01:11.000000000 +0100
+@@ -43,20 +43,16 @@
+ else echo Bleeding Edge Version; \
+ fi;)
+
+-CC = gcc
+-CPPFLAGS =
+-
+ # for production
+-CFLAGS = -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
+- -I /usr/X11R6/include
+-LDFLAGS = -s
++CFLAGS += -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
++ $(shell pkg-config --cflags x11)
+
+ # for testing
+ #CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
+ -I /usr/X11R6/include
+ #LDFLAGS =
+
+-LIBS = -L/usr/X11R6/lib -lX11 -lutil
++LIBS = $(shell pkg-config --libs x11) -lutil
+
+ OBJS = main.o util.o
+
+@@ -76,5 +72,7 @@
+ rm -f $(EXEC) *.o core *~
+
+ install: $(EXEC)
+- cp $(EXEC) $(BINDIR)
+- cp $(MANFILE) $(MANDIR)
++ install -d $(BINDIR)
++ install -d $(MANDIR)
++ install $(EXEC) $(BINDIR)
++ install $(MANFILE) $(MANDIR)
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch
new file mode 100644
index 000000000000..8d85400fcd05
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch
@@ -0,0 +1,22 @@
+--- a/xrootconsole.1.orig 2005-03-06 16:59:05.837673328 +0900
++++ b/xrootconsole.1 2005-03-06 17:04:36.493406016 +0900
+@@ -38,6 +38,9 @@
+ .Ar number
+ columns wide. Text is written vertically down each column in the order in
+ which text is received from the input file. The default is 1.
++.It Fl -solid
++This option makes the background a solid color. The default is to use a
++shaded/transparent background.
+ .It Fl -topdown
+ Forces xrootconsole to display new lines from its input at the top of the
+ screen, scrolling previous lines down. Default behavior is to insert new
+@@ -45,6 +48,9 @@
+ .It Fl -wrap
+ Rather than truncating long lines, this option specifies that xrootconsole
+ should wrap excess text to the following line or lines, as necessary.
++.It Fl -noversion
++Tells xrootconsole not to display its version as the first line of output in
++the root window. Default behavior is to include version information.
+ .It Fl geometry Ar geometry
+ This option specifies the preferred size and position of the window; see
+ .Xr X 1 .
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch
new file mode 100644
index 000000000000..50587f7437cb
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch
@@ -0,0 +1,52 @@
+--- a/main.c.orig 2004-02-21 07:31:53.000000000 +0900
++++ b/main.c 2005-03-06 16:34:27.949346504 +0900
+@@ -68,6 +68,7 @@
+ " --solid make background a solid color, not shaded-transparent\n" \
+ " --topdown insert lines at the top and scroll the rest down\n" \
+ " --wrap wrap long lines, instead of cutting them off\n" \
++" --noversion do not display xrootwindow version in output\n" \
+ " -h or --help a familiar-looking help screen\n" \
+ " -v or --version displays the version number\n" \
+ " [console] filename to read (defaults to standard input)\n" \
+@@ -102,6 +103,7 @@
+ int wrap;
+ int topdown;
+ int solid;
++ int show_version;
+ } InitOptions;
+
+ typedef struct {
+@@ -219,6 +221,7 @@
+ io->wrap = DEFAULT_WRAP;
+ io->topdown = DEFAULT_TOPDOWN;
+ io->solid = DEFAULT_SOLID;
++ io->show_version = 1;
+
+ /* Process command-line arguments */
+ while (*++argv != NULL) {
+@@ -236,6 +239,8 @@
+ io->bw = atoi(*++argv);
+ else if (!strcmp(*argv, "-columns") || !strcmp(*argv, "-c"))
+ io->tc = atoi(*++argv);
++ else if (!strcmp(*argv, "--noversion"))
++ io->show_version = 0;
+ else if (!strcmp(*argv, "--solid"))
+ io->solid = True;
+ else if (!strcmp(*argv, "--wrap"))
+@@ -560,10 +565,12 @@
+ init_console(io.console_name, ws.colwidth, ws.nlines, &cs);
+
+ /* Display a message */
+- put("xrootconsole ",&io,&ws,&cs);
+- put(XROOTCONSOLE_VERSION,&io,&ws,&cs);
+- put("\n",&io,&ws,&cs);
+-
++ if (io.show_version) {
++ put("xrootconsole ",&io,&ws,&cs);
++ put(XROOTCONSOLE_VERSION,&io,&ws,&cs);
++ put("\n",&io,&ws,&cs);
++ }
++
+ draw_pixmap(&io,&ws,&cs);
+
+ event_loop(&io,&ws,&cs);