summaryrefslogtreecommitdiff
path: root/x11-misc/xdock/xdock-0.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdock/xdock-0.3.0-r1.ebuild')
-rw-r--r--x11-misc/xdock/xdock-0.3.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xdock/xdock-0.3.0-r1.ebuild b/x11-misc/xdock/xdock-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..4c830a3fe0f3
--- /dev/null
+++ b/x11-misc/xdock/xdock-0.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Emulates Window Maker docks (runs in any window manager)"
+HOMEPAGE="https://xdock.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( API AUTHORS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.0-ldconfig.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}