summaryrefslogtreecommitdiff
path: root/x11-misc/xcape/xcape-1.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xcape/xcape-1.2-r1.ebuild')
-rw-r--r--x11-misc/xcape/xcape-1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/xcape/xcape-1.2-r1.ebuild b/x11-misc/xcape/xcape-1.2-r1.ebuild
new file mode 100644
index 000000000000..8b524c8c6a55
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}