summaryrefslogtreecommitdiff
path: root/x11-misc/whaw/whaw-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/whaw/whaw-0.2.ebuild')
-rw-r--r--x11-misc/whaw/whaw-0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/whaw/whaw-0.2.ebuild b/x11-misc/whaw/whaw-0.2.ebuild
new file mode 100644
index 000000000000..ca7e6ab903de
--- /dev/null
+++ b/x11-misc/whaw/whaw-0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Window manager independent Window Layout tool"
+HOMEPAGE="http://repetae.net/computer/whaw/"
+SRC_URI="http://repetae.net/computer/${PN}/drop/whaw-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/popt
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-implicit-declaration-warning.patch"
+ epatch_user
+}