summaryrefslogtreecommitdiff
path: root/x11-misc/sux/sux-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sux/sux-1.0.1.ebuild')
-rw-r--r--x11-misc/sux/sux-1.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/sux/sux-1.0.1.ebuild b/x11-misc/sux/sux-1.0.1.ebuild
new file mode 100644
index 000000000000..8619606a8840
--- /dev/null
+++ b/x11-misc/sux/sux-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="\"su\" wrapper which transfers X credentials"
+HOMEPAGE="http://fgouget.free.fr/sux/sux-readme.shtml"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-apps/xauth"
+DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-xauth-and-home.patch
+)
+
+
+src_install() {
+ dobin ${PN}{,term}
+ dodoc TODO
+ newdoc debian/changelog Debian.changelog
+ doman debian/${PN}{,term}.1
+}