summaryrefslogtreecommitdiff
path: root/x11-misc/sunflower/sunflower-0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.5.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.5.ebuild b/x11-misc/sunflower/sunflower-0.5.ebuild
new file mode 100644
index 000000000000..e4571e23d968
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+MY_PN="Sunflower"
+MY_PV="${PV}-63"
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://github.com/MeanEYE/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # Upstream's get_version requires a lot of BDEPENDS we do not want.
+ sed 's%version=get_version()%version="0.5"%g' -i setup.py
+}