summaryrefslogtreecommitdiff
path: root/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild')
-rw-r--r--x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild b/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild
new file mode 100644
index 000000000000..8382ae2c2094
--- /dev/null
+++ b/x11-misc/sisctrl/sisctrl-0.0.20051202.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="tool that allows you to tune SiS drivers from X"
+HOMEPAGE="http://www.winischhofer.net/linuxsispart1.shtml#sisctrl"
+SRC_URI="http://www.winischhofer.net/sis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libXrender
+ x11-libs/libXv
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-xv.patch
+ sed -i -e 's,/X11R6,,g' configure || die
+ append-flags -lm
+}