summaryrefslogtreecommitdiff
path: root/x11-misc/oroborus-keylaunch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/oroborus-keylaunch')
-rw-r--r--x11-misc/oroborus-keylaunch/Manifest3
-rw-r--r--x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch44
-rw-r--r--x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild (renamed from x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild)25
3 files changed, 56 insertions, 16 deletions
diff --git a/x11-misc/oroborus-keylaunch/Manifest b/x11-misc/oroborus-keylaunch/Manifest
index 1630f2b5ee0c..7f83cb6b1ba8 100644
--- a/x11-misc/oroborus-keylaunch/Manifest
+++ b/x11-misc/oroborus-keylaunch/Manifest
@@ -1,3 +1,4 @@
+AUX oroborus-keylaunch-1.3.9-makefile.patch 1015 BLAKE2B 6e21d53bfeb6f82d16970fbffffb9b88c2a333b2934f9eed430ba4aa8251097ce426e122fed365b7af3683f0cebb1fed2cdff35f7ba293cf62ce4eb8647147a1 SHA512 50fcdf43013bd52d42ccce12ba59ffcbc813dd8586823914f23677e8ca15954c11e9f1b853ec5009eb96382db001a1c7a7c5d46189a54e0e3b6c9c54a222515d
DIST keylaunch_1.3.9.tar.gz 80286 BLAKE2B b91df64c6efa3b49039cfbc561d0ad512ebd71c3f74797f55be9acf4a3642f61fc6a3a6b4115e311005719b141e1df7098756e555a319ded2a4b984b9e8a5c1a SHA512 9955bb913dec9c39aa4be86410229b2952738fca2c7a77f7d61d2750c880e4cbd59fd82979c441780b3a5aa5ce12b3a9863526f610feec5c5b30c65476c50c10
-EBUILD oroborus-keylaunch-1.3.9-r1.ebuild 659 BLAKE2B 7c34a3d8cf5dc58c9864af004bdf64fdb290df5bceeb9155ef97c2a12ef44f2e916ef07648e2f72a7b35f8052c11b36425f511bdcd79e42575c7154ad1a5dc2e SHA512 7746badf1c9c52addb26f906db5e673b18232f53d1ce808611ca9dd1284ce3097986ed29e8775a21fb30d32d98c4100d463fb3a6fcb4a5239de9bbd811d9125b
+EBUILD oroborus-keylaunch-1.3.9-r2.ebuild 606 BLAKE2B 6a4d75eb0a5d082f6fe7b5a0eb49e8acebd8d125daf6cda399262886b9e757e32ef147a68cff58a2ad194e938ed74c01fef07496b485c1c42d41ad89fcd36471 SHA512 48b9fc851b2df9bcfa5d99bb01dfcdac9e4f563e177998a250dad1c83340d937be6cda0f48a03cda73066508b4cc6c6dd216cd2230773bc2bcd6cf8955a06dfe
MISC metadata.xml 411 BLAKE2B 15b353e7a32f46bf6cdfecffc5d9110ece837233218d6bc5f1db0f4310f57220f178c2a2e205759d1a1a75017e927102a6de0150df91546770d9fbb88a6a4318 SHA512 45c9dcda675ab97720eb58c2120007f9b0c74f903daf24451b698b2975cc1fa11dfbc77ad2b089b361c86b42fcdee23aeda71c6e2fe254455885a5d00fec7d8a
diff --git a/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch b/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch
new file mode 100644
index 000000000000..523fd85aa0eb
--- /dev/null
+++ b/x11-misc/oroborus-keylaunch/files/oroborus-keylaunch-1.3.9-makefile.patch
@@ -0,0 +1,44 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -14,7 +14,7 @@
+ DOC_DIR = $(INSTDIR)/share/doc/$(PROG)
+
+
+-VERBOSE =
++VERBOSE = 1
+ ifeq ($(VERBOSE), 1)
+ Q =
+ else
+@@ -22,7 +22,8 @@
+ endif
+
+ CC = @CC@
+-CFLAGS = @CFLAGS@ @X_CFLAGS@ -g -O2 -Wall
++CFLAGS = @CFLAGS@ @X_CFLAGS@
++CPPFLAGS = @CPPFLAGS@
+ LIBS = @LIBS@ @X_LIBS@
+ LDFLAGS = @LDFLAGS@
+ RCFILE = .$(PROG)rc
+@@ -55,11 +56,11 @@
+
+ $(PROG): $(OBJS)
+ @echo "[ linking $< ]"
+- $Q$(CC) $< $(LDFLAGS) $(LIBS) -o $@
++ $Q$(CC) $(LDFLAGS) $(CFLAGS) $< -o $@ $(LIBS)
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ @echo "[ compiling $< ]"
+- $Q$(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
++ $Q$(CC) $(CFLAGS) $(CPPFLAGS) $(DEFINES) -c $< -o $@
+
+ install-mans:
+ @echo "[ installing manpages. (section 1) ]"
+@@ -71,7 +72,7 @@
+ $Q$(INSTALL) $(INST_CREATEDIR) $(DOC_DIR)
+ $Q$(INSTALL) $(INST_DOC_OPTS) $(DOCS) $(DOC_DIR)
+
+-install: all install-mans install-docs
++install: all install-mans
+ @echo "[ installing $(PROG) ]"
+ $Q$(INSTALL) $(INST_PROG_OPTS) $(PROG) $(BIN_DIR)/$(PROG)
+
diff --git a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild
index aade3f2ad749..e3907005102c 100644
--- a/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r1.ebuild
+++ b/x11-misc/oroborus-keylaunch/oroborus-keylaunch-1.3.9-r2.ebuild
@@ -1,34 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+WANT_AUTOMAKE=none
+inherit autotools
MY_PN=${PN/oroborus-//}
DESCRIPTION="utility for binding keys in Oroborus"
HOMEPAGE="https://www.oroborus.org"
SRC_URI="mirror://debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="x11-libs/libX11
- !x11-wm/oroborus-extras"
-RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_PN}-${PV}
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
DOCS=( README docs/example_rc debian/changelog )
src_prepare() {
default
- sed -e "s: -g -O2 -Wall::" \
- -e "/^install:/s/install-docs//" \
- -i Makefile.in || die
-}
-
-src_compile() {
- emake VERBOSE=1
+ eautoconf # bug 898254
}