summaryrefslogtreecommitdiff
path: root/x11-misc/mate-notification-daemon
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest2
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index 743d12112cac..c08cc87f02cc 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,4 +1,6 @@
AUX org.freedesktop.Notifications.service 94 BLAKE2B 1a97aac2db9c803c9e4babf9067283b564a1eecb1d251aee3a5e66b8a4f63d2554e3e09ea06749383ce3d5b8e77c8cc3bd87ae2dde48ae8feb4886ecaf7a3c27 SHA512 0575cbfc094455c0a2f04faa534a5e0d9cc41e6d9566ab9bcb0fcbce99e142213ded786ad00c36dc434ae1b9208d34d234a341dfc86adb72925dad0ee2b25f97
DIST mate-notification-daemon-1.24.0.tar.xz 392588 BLAKE2B 480272848b3403d34eaa1f555a573dbf74a4e8e45e76c4726943bda4c29d7002f00d1a828e318d51dd07a44df1c64902c38bbe41c1c14339e8cb8710f7008f36 SHA512 0fd2da98001c60672d4833e974ac74dd561f54ca6f3fd74f8d6620e3b28768add46dd891d7446b01426b6aed09d4966d902cbde45aac3498fdcbb837e531a147
+DIST mate-notification-daemon-1.24.1.tar.xz 395444 BLAKE2B dca166664216c7027b2e816c7df64636c3f1c7ae25db253167f9c5d1b296cd9bf3c7533e1f7a33a7d4f2bf5fe074e8f0911462463fffa5b839fd8decd62a4716 SHA512 7c799e31229860cb34fa4a19421360a4a93d81826bc4381ed284e1ec280bae67d2f5bdf5d751f3dad6a1da424a5c598b2def60b7b24fd6ea41da5f126f456bac
EBUILD mate-notification-daemon-1.24.0.ebuild 1028 BLAKE2B 628a6b16802acc6b15febaaa876d4ef6f7fd053e2d2bc3930c4658c13d72dc460f585db90865594179c359551774b1bcf800fea2e72b0235663abb4530075d0e SHA512 df275daceeb8e1d5ee36f37f3c7007710a69540ca4d528c93a28eea494e087510cd64c6753cf7cecfc1a008b9512033f676922ac00480474d0f39ccc88c6e1b8
+EBUILD mate-notification-daemon-1.24.1.ebuild 994 BLAKE2B 1f168864632ef98659fa44f1079cab355fef086169c70664b6ce5367f36114dbda78c3dd7085b92b20dbf10be7b5c654e758417bdc454afa05227542c19566a0 SHA512 8a80b2ee8af7927e740a5b857f74319b087a1a8e77c977bea44db10b63de1da4a12f40ef4ed408fedaae8ed016a59351200bf6391e0344fa49f686f0747945e9
MISC metadata.xml 353 BLAKE2B 774bcae8807bbb16a1ee8bc12320e487ec817fb45d3169f4929cbd8c3f7f33a35eb1aad2682e5d87131567c56e6ffe8f2bdbda612c58926ddc3d78b14cb69e53 SHA512 3f46b4bb5e12fdb448e7b7f54db4f4a4683cbdbd89019156601abf80be0333690b65670fb110120cf613dd42ecdfb38b329ddde67fd265257d6ddb32e24bfbbd
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild
new file mode 100644
index 000000000000..b419b74c0364
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}