summaryrefslogtreecommitdiff
path: root/x11-misc/i3lock/i3lock-2.12-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3lock/i3lock-2.12-r2.ebuild')
-rw-r--r--x11-misc/i3lock/i3lock-2.12-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/i3lock/i3lock-2.12-r2.ebuild b/x11-misc/i3lock/i3lock-2.12-r2.ebuild
new file mode 100644
index 000000000000..07a68eb55c25
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.12-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.12-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}