summaryrefslogtreecommitdiff
path: root/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3blocks/i3blocks-1.5-r1.ebuild')
-rw-r--r--x11-misc/i3blocks/i3blocks-1.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild b/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
new file mode 100644
index 000000000000..418265489eaa
--- /dev/null
+++ b/x11-misc/i3blocks/i3blocks-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="highly flexible status line for the i3 window manager"
+HOMEPAGE="https://github.com/vivien/i3blocks"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vivien/${PN}"
+else
+ SRC_URI="https://github.com/vivien/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="+contrib"
+SLOT="0"
+LICENSE="GPL-3"
+
+PDEPEND="contrib? ( x11-misc/i3blocks-contrib )"
+
+PATCHES=( "${FILESDIR}"/${PN}-disable-bash-completion.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newbashcomp bash-completion ${PN}
+}