summaryrefslogtreecommitdiff
path: root/x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild')
-rw-r--r--x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild28
1 files changed, 6 insertions, 22 deletions
diff --git a/x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild b/x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild
index 98d5e081d8c8..9f5e5fba792a 100644
--- a/x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild
+++ b/x11-misc/gtkdialog/gtkdialog-0.8.3_p20200202.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools xdg-utils
+EAPI=8
+inherit autotools xdg
DESCRIPTION="A small utility for fast and easy GUI building"
HOMEPAGE="https://github.com/oshazard/gtkdialog"
@@ -11,17 +11,10 @@ SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="gtk2"
RDEPEND="
- gtk2? (
- x11-libs/gtk+:2
- x11-libs/vte:0=
- )
- !gtk2? (
- x11-libs/gtk+:3
- x11-libs/vte:2.91=
- )
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91=
"
DEPEND="
${RDEPEND}
@@ -41,8 +34,7 @@ src_prepare() {
}
src_configure() {
- econf \
- $(usex gtk2 --disable-gtk3 --enable-gtk3)
+ econf --enable-gtk3
}
src_compile() {
@@ -55,11 +47,3 @@ src_install() {
emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
einstalldocs
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}