summaryrefslogtreecommitdiff
path: root/x11-misc/fpm2/fpm2-0.90.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/fpm2/fpm2-0.90.ebuild')
-rw-r--r--x11-misc/fpm2/fpm2-0.90.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/fpm2/fpm2-0.90.ebuild b/x11-misc/fpm2/fpm2-0.90.ebuild
new file mode 100644
index 000000000000..0a7f6ea19f0d
--- /dev/null
+++ b/x11-misc/fpm2/fpm2-0.90.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="A GUI password manager utility with password generator"
+HOMEPAGE="https://als.regnet.cz/fpm2/"
+SRC_URI="https://als.regnet.cz/${PN}/download/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/nettle
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # gettext make check failure
+ echo "data/fpm2.desktop.in" >> po/POTFILES.in || die
+}