summaryrefslogtreecommitdiff
path: root/x11-misc/arandr/arandr-0.1.10-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/arandr/arandr-0.1.10-r2.ebuild')
-rw-r--r--x11-misc/arandr/arandr-0.1.10-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/arandr/arandr-0.1.10-r2.ebuild b/x11-misc/arandr/arandr-0.1.10-r2.ebuild
new file mode 100644
index 000000000000..93d18823f081
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.10-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Another XRandR GUI"
+HOMEPAGE="https://christian.amsuess.com/tools/arandr/"
+SRC_URI="https://christian.amsuess.com/tools/arandr/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+RDEPEND="
+ dev-python/pygobject:3=[${PYTHON_USEDEP},cairo]
+ x11-libs/gtk+:3[introspection]
+ x11-apps/xrandr
+"
+
+BDEPEND="dev-python/docutils[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.10-manpages.patch" )