summaryrefslogtreecommitdiff
path: root/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch')
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
new file mode 100644
index 000000000000..c32dccaa09d7
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 12657be..c14ca89 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ cmake_minimum_required(VERSION 3.16)
++include(GNUInstallDirs)
+
+ project( QwtPlot3D
+ VERSION 0.3.0
+@@ -104,8 +105,12 @@ set( HEADERS
+ "include/qwt3d_io_gl2ps.h"
+ )
+ configure_file( "include/qwt3d_version.h.in" "qwt3d_version.h" @ONLY )
++list( APPEND HEADERS
++ "${CMAKE_BINARY_DIR}/qwt3d_version.h"
++ )
+
+ add_library( qwtplot3d ${SRCS} ${HEADERS} )
++set_target_properties( qwtplot3d PROPERTIES PUBLIC_HEADER "${HEADERS}" )
+
+ target_link_libraries( qwtplot3d
+ Qt${QT_VERSION_MAJOR}::Core