summaryrefslogtreecommitdiff
path: root/x11-libs/pixman/pixman-0.40.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/pixman/pixman-0.40.0.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.40.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-libs/pixman/pixman-0.40.0.ebuild b/x11-libs/pixman/pixman-0.40.0.ebuild
index 90fff3bb9046..a269bcee7084 100644
--- a/x11-libs/pixman/pixman-0.40.0.ebuild
+++ b/x11-libs/pixman/pixman-0.40.0.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson-multilib multiprocessing toolchain-funcs
+inherit ${GIT_ECLASS} flag-o-matic meson-multilib multiprocessing toolchain-funcs
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -28,6 +28,11 @@ multilib_src_configure() {
local openmp=disabled
tc-has-openmp && openmp=enabled
+ if use arm && tc-is-clang ; then
+ # See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
+ append-cflags $(test-flags-CC -fno-integrated-as)
+ fi
+
local emesonargs=(
$(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
$(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)