summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.10.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index e2949a187f14..b8f3c727c9d9 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
+DIST libxkbcommon-0.10.0.tar.xz 383788 BLAKE2B 0e2cc110c35a4d07cfd55a46a4cc30038bc296f74522beb97b72d0318799adb76fa514427640f286254de7aa59fb8b8c26de5d8fd52f7e09c5ba3521febb97bd SHA512 58c523b42a8ea0cae7322d453fbc5d4624374221246cb067074e2ff9820eef3ceea8686283136432cdf0842acfc0858c7b2d3954de234b6501092ae1d27c9e79
DIST libxkbcommon-0.9.1.tar.xz 376164 BLAKE2B 16c95081136ea9ce742f494ae2192cce815f3fb4a3d33d3e525f8ad61f1f720fa6bfe74088a9ab88f3c6ef9cdf78c4d8d4dc87e7478fd84e4b09e03a337efbdf SHA512 8d4551a06e7dd4936633f544409401dc33f8f1900adb5daa6403615c71f321d17212db739f89a5b3e393d729b3f33167691404849a25d5526b403fd9ec3e8878
+EBUILD libxkbcommon-0.10.0.ebuild 1226 BLAKE2B 838ec970caa72c84b24c3c67389d91ba5dcbdc23191151e61abfe574b77809b6b98492a47f7e696a0aedf96d08d8867334938e09e7dcce168861092dc7293725 SHA512 de971c96b741b86aac3b9e9e9764f011ec1546d05f1eb0b0d164f3a66ac39b952169c59eef67c121c82b1be762c3ca13dd993eda7d819ec7e70553a5bd8382e8
EBUILD libxkbcommon-0.9.1.ebuild 1216 BLAKE2B 82435dab35e380f00f48f0d1fb3a54e8c22e163913e72189859039f10fa83dc0498893cdb8ab0c7195164874cc51176735d78e16adc187e4665354d48a4e9a3c SHA512 2628f7a00dc614764708aad7a88830f6b68e4c2291866c9e29f4b5747ff55aa142091f647c4dc6dcfd62aaf4815d2eb050e65d95dda35fb4603bc2437bcbc900
MISC metadata.xml 325 BLAKE2B db764fac0ca1f4359bcd129dc165f78592535dee40bc25b6f2d7c662bdce43e01cc66b362765607665a75fc5b1703de204cf90eecae4f8d285cfaefcebc614b8 SHA512 ca2a116a574783f7b3c6191759c902e2cb059ec135456cef989b81be07fecc48f9ff56e02845d18c2376c99be3dd9711f39ad91394e421fa36d8fd6453c0a121
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.10.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.10.0.ebuild
new file mode 100644
index 000000000000..473a7228d16e
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="X doc test"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Denable-wayland=false # Demo applications
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}