summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.10.0-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 78cfd518f674..b42febcc2d51 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,4 @@
DIST libxkbcommon-0.10.0.tar.xz 383788 BLAKE2B 0e2cc110c35a4d07cfd55a46a4cc30038bc296f74522beb97b72d0318799adb76fa514427640f286254de7aa59fb8b8c26de5d8fd52f7e09c5ba3521febb97bd SHA512 58c523b42a8ea0cae7322d453fbc5d4624374221246cb067074e2ff9820eef3ceea8686283136432cdf0842acfc0858c7b2d3954de234b6501092ae1d27c9e79
+EBUILD libxkbcommon-0.10.0-r1.ebuild 1292 BLAKE2B 58b41eb81edce585c966a1ef1041ac7236da6565b90a2a514e12a729937400e542fe113230cf2a2dde1e348b3f38796809f661dd6c2b3ece4af2d362a5d0ec4e SHA512 dece8d99a0018f03604153358549cddf09a4a4a6853b32229080d17fe3ef7616f13e989c76c03c3af35d2548e55f1c790954f1b4dd5244d28f738ede9d42dc81
EBUILD libxkbcommon-0.10.0.ebuild 1218 BLAKE2B 3b48076803a2d153b2ed82b24c28839deebf1de52d1ca2f1b830ffd774a0dcf4d29a8a5701ea3d7795d374b516fab4303225aacbd499cf2e9e15402a78d2c05c SHA512 9700d6fcfb3e0580d0e6b3c01d20b8778f5363f3b6bdd67e5014b846980786c7a68537ba5e71a177e5c2a3b05322fc28b46992efece09a1be62faeb04d81dbe0
MISC metadata.xml 325 BLAKE2B db764fac0ca1f4359bcd129dc165f78592535dee40bc25b6f2d7c662bdce43e01cc66b362765607665a75fc5b1703de204cf90eecae4f8d285cfaefcebc614b8 SHA512 ca2a116a574783f7b3c6191759c902e2cb059ec135456cef989b81be07fecc48f9ff56e02845d18c2376c99be3dd9711f39ad91394e421fa36d8fd6453c0a121
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.10.0-r1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..15fdecd2c429
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.10.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="X doc static-libs test"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Denable-wayland=false # Demo applications
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}