summaryrefslogtreecommitdiff
path: root/x11-libs/libva/libva-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libva/libva-9999.ebuild')
-rw-r--r--x11-libs/libva/libva-9999.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 016d79e6442e..812111b4ebad 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,14 +8,19 @@ inherit multilib-minimal
DESCRIPTION="Video Acceleration (VA) API for Linux"
HOMEPAGE="https://01.org/linuxmedia/vaapi"
-if [[ ${PV} = *9999* ]] ; then # Live ebuild
- inherit autotools git-r3
+inherit autotools
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
EGIT_BRANCH=master
EGIT_REPO_URI="https://github.com/intel/libva"
- AUTOTOOLS_AUTORECONF="yes"
else
- SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ # SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
+ # The upstream provides periodically tarball with pre-built 'configure'.
+ # To simplify updates, portage use tarballs without pre-build 'configure'
+ # which are always available.
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
@@ -52,19 +57,20 @@ PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB
REQUIRED_USE="|| ( drm wayland X )
opengl? ( X )"
-DOCS=( NEWS )
+# CONTRIBUTING.md and README.md are avaialbe only in .tar.gz tarballs and in git
+DOCS=( NEWS CONTRIBUTING.md README.md )
MULTILIB_WRAPPED_HEADERS=(
-/usr/include/va/va_backend_glx.h
-/usr/include/va/va_x11.h
-/usr/include/va/va_dri2.h
-/usr/include/va/va_dricommon.h
-/usr/include/va/va_glx.h
+ /usr/include/va/va_backend_glx.h
+ /usr/include/va/va_x11.h
+ /usr/include/va/va_dri2.h
+ /usr/include/va/va_dricommon.h
+ /usr/include/va/va_glx.h
)
src_prepare() {
default
- [[ "${PV}" == *9999* ]] && eautoreconf
+ eautoreconf
}
multilib_src_configure() {
@@ -74,10 +80,12 @@ multilib_src_configure() {
$(use_enable X x11)
$(use_enable wayland)
$(use_enable drm)
+ --enable-va-messaging
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
+ default
find "${ED}" -type f -name "*.la" -delete || die
}