summaryrefslogtreecommitdiff
path: root/x11-libs/libtinynotify-systemwide
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libtinynotify-systemwide')
-rw-r--r--x11-libs/libtinynotify-systemwide/Manifest6
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild33
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild42
-rw-r--r--x11-libs/libtinynotify-systemwide/metadata.xml16
4 files changed, 97 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify-systemwide/Manifest b/x11-libs/libtinynotify-systemwide/Manifest
new file mode 100644
index 000000000000..df03f4e9840d
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/Manifest
@@ -0,0 +1,6 @@
+DIST libtinynotify-systemwide-0.1.tar.bz2 270071 SHA256 ae2c3bb845eec3eae8921b7887f0cbbc9f468012020c2d6e2c18e30f8d858217 SHA512 95516208485ed46e4702806bca467af509b9756a738f5f345cec712d878f14f4d9c84b78c33f0e4a41e0bf7be3b6e8e50dcd230da753c2827ae75793ca1c74aa WHIRLPOOL 4d40e217ddd44e64e45bcd47f7d0c0f59e7d3c545cd3f921bcec1f2697dd26ce8f2a2633b1382509616cbbb8402f47632b7b205f6820eee86e13002461b51bf9
+EBUILD libtinynotify-systemwide-0.1.ebuild 734 SHA256 8628023d847c4ea071799c3f6397da81e2a1f73db3f65981b514a40aa972a052 SHA512 eea53d38f575434dfd3644739d61e4ec809a24406d4af2f790b7bcabe399f08451bc315e94c2cb28dbdc928166a09d7c26c4f6c0810601a55750044e3c01cd8a WHIRLPOOL 483d7c44f7dfacb255b92df335dd17419b4272dec057b7dc7f61d7f62b220b4b78e67635e209388959f72041ab236a21531154ac18890324b8e533b5579b3b5f
+EBUILD libtinynotify-systemwide-9999.ebuild 781 SHA256 d01a22d3bd18a327033f642c1d730ad46c568993e59c16c3ff1bb6998d4bb4a4 SHA512 c2714ac7278600a487112bf7e61427a0124e9d892871c7ce32151bef56bfe2f9926b9e95df369c74568edf96ac5787b4e4a5cf51d14702d8224dd02279fe4ad6 WHIRLPOOL 6b95721dba904ba78c986b358fb8bb979d99aa21259ab4907cc77ccdfa60663ea9ad04ae059b12a88562d578e87d1b1641ccb4e7e47d443c67867139971cbd9b
+MISC ChangeLog 3099 SHA256 fb10a26ffa999c01affb19350c643469b044313312100771fdfd140bf958bab9 SHA512 c06815f1c8e0367eb97ae4281769f6bf716cbd41437af6bdfc67db149e37056fb264a54054e5c949a1f49276b677770c1ddf42a24271ea0e14e360e694048d4c WHIRLPOOL 9e856cf55e83021ba42075e837afa9ae8dbf117678434cf1f7b0083097f4e9e5b772e0d8e9a1b5dc66394b4e8ec333ad2f5a814bc6945e4e584ed717fee2931d
+MISC ChangeLog-2015 1650 SHA256 42b1ca61bce7de089d0fad7f4fc7bf572d5c10567fbbaf4123b71214c5d0eeb3 SHA512 926eb85b9373e02f1e9af6b84bf74fd0f0566ec128cd7b674f341101ae18c52ceba53f564621b989949bbfa325036aa56392a25fd8b8707fd6bacc5c775a2ad2 WHIRLPOOL 06790b7814e717bcddc5821b7423a738c52ba59da33a995c74eb62a8d1697663523c7318a34e509f911e55fbfe0b3360b945cd3d272ce251e977a2e9f63dfc45
+MISC metadata.xml 537 SHA256 8afc2624998ca23fbdde48773202ea0000a6dfead5eb12c499bade95c23a0f48 SHA512 31be52e470c741fff7b2d40c325e3310550a3f0816ca66d8be1318a56bc1283e39785e9544d99c241ed8c0bb07a224c162268f050888072cfb1b62e49f8c5cc2 WHIRLPOOL b2168637191433ffc0582f3d00a0ae26c9f7a0772931ba013fb65ad40154f0f3c0f98b3dda81c922da3c9e7b88332b0f041e6191a703ee913304a87165f0f1b9
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
new file mode 100644
index 000000000000..4543af991c3e
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
+SRC_URI="https://github.com/mgorny/libtinynotify-systemwide/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps:0=
+ x11-libs/libtinynotify:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
new file mode 100644
index 000000000000..d4effe7755cf
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+inherit autotools git-r3
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps:0=
+ x11-libs/libtinynotify:0="
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.18
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-libs/libtinynotify-systemwide/metadata.xml b/x11-libs/libtinynotify-systemwide/metadata.xml
new file mode 100644
index 000000000000..b393cf15509e
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/libtinynotify-systemwide/issues/</bugs-to>
+ <remote-id type="github">mgorny/libtinynotify-systemwide</remote-id>
+ </upstream>
+</pkgmetadata>