summaryrefslogtreecommitdiff
path: root/x11-libs/libX11/libX11-1.6.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libX11/libX11-1.6.10.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.6.10.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libX11/libX11-1.6.10.ebuild b/x11-libs/libX11/libX11-1.6.10.ebuild
new file mode 100644
index 000000000000..332f2c8108d0
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.6.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ !<x11-base/xorg-proto-2019.2"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+}