summaryrefslogtreecommitdiff
path: root/x11-libs/gl2ps
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/Manifest6
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch74
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.9.ebuild53
-rw-r--r--x11-libs/gl2ps/metadata.xml17
4 files changed, 150 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/Manifest b/x11-libs/gl2ps/Manifest
new file mode 100644
index 000000000000..d1486521a86e
--- /dev/null
+++ b/x11-libs/gl2ps/Manifest
@@ -0,0 +1,6 @@
+AUX gl2ps-1.3.8-cmake.patch 2410 SHA256 cbf849f8a68223a10802cac332fdf6af38a34f075d3b8f6e5957942df30d2f0d SHA512 9ae64f280ff72e88cccd8daedec283ffef3403a02dbfa5872ec8991a1b6f0c6e0afaa1ff5009ada99cf9a3bb051dccf61614a77947728140b516081de8a624bd WHIRLPOOL 4342f59cf14c4fac95e62772d6ce0619b7a6edc930c7dcd6b27fb6e41e6a42c9e7286c21790a9da3375fd0311976c9e7854f5e01804e8be4f8a7ab7754259bb7
+DIST gl2ps-1.3.9.tgz 294907 SHA256 8a680bff120df8bcd78afac276cdc38041fed617f2721bade01213362bcc3640 SHA512 e6770c27d4832a300b4e16a9f98deb8557e7875460e7aa7e655fdb796f5dfffd5eccdc8b15f5a3ae151713fc46f97dacad48ee7550c41373b6fc8cfd21a437cb WHIRLPOOL 2ba0611daa39814a02c97ceec70c2e36b46881371a6a4790c5f5db4ea7e8b3352a25228d3aab60d2ec5b6f9e5070d9a7f331ebed2df355a6444f4e20365d7915
+EBUILD gl2ps-1.3.9.ebuild 1247 SHA256 45e568b1ef7d6569f402c9539c26f8ab537de3efd91d5b70e3a357a2d129165d SHA512 02328e81109ab6dd6307174217d105f49de9dcc30fcba6ceeda219ae00927eee27e4991aff6dbf8cf5ac72344c210f3545a5cf75a7d2d445a3263d57a457b9fa WHIRLPOOL e9ab95daa1f0e6f96226b8d61156e12c53de2b56335f65f1f4c33319845fd9ba5b35eb154351688a30eee432e10e2c457cd7566a731509c9d8cb163944baf22a
+MISC ChangeLog 2834 SHA256 a425775c827a9a27bb52268491257a9e1c174f53562cd2b72d1b211951e1f1dc SHA512 b9cb23a761d8b55146be25a9db89af1ff7da951b87a958ac0d3dfec2ffc0edae71dd0e515e45a29416ffdb3595be98e1e0837cf089c72d60eb9ab3839c95f2b1 WHIRLPOOL d74c97f320a77fff93497db5cea7a18e0185249ce1f2ad3e6636df4f7227882190b9c2fbc03b945b9fc9ade45c740b23beebe605ec6f189e2c28e9c294fe7f93
+MISC ChangeLog-2015 4046 SHA256 f3677fe19561e4cf4e65f9e3e4a633cb79a0a94847c686669abbfc6591b69dcf SHA512 17eecae47ac3714cd476fefd9a4d694931d05e0a77719c8dbee633bafe34903fb7d73cd5a868429767a478e889048dcf20a9bbad71267cb95adc4eddfecb8385 WHIRLPOOL da8ca2fa2f41d43e406c6d2bf37a8dc49210778a4d279d387bc466231cf6d89290c58261820ba2fc8e98bcd30ec189454ad808eb8e9e0caee2a51839fb2049dc
+MISC metadata.xml 721 SHA256 22151bdca524b72b74f092b6a1df445b66b49073f438d040367b2e6e51993ffb SHA512 272fa0b10d317453f463cde0157c28630273426351e01163d8a444848e3cb4f347b959f495f3973124281cfb9880f92e4e828abde735bfaa7b7b4e9c594ecfec WHIRLPOOL 04969199c5867a910520986a8d272d970bb06dfc2b95abba72ae367d0a0c19e71ceb188598c0ad5f6ee0ac781c6cf60b63c31a812e2771b8d6898a8a0234e770
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
new file mode 100644
index 000000000000..f22760fd6eca
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.8-cmake.patch
@@ -0,0 +1,74 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+
+Patch to add various enhancements to cmake:
+* use GNU standard CMAKE_INSTALL_DOCDIR
+* optional documenation building
+* optional examples building
+* do not install static libraries
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,6 +46,8 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
++option(ENABLE_EXAMPLES "Build and install examples" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +105,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +116,32 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib${LIB_SUFFIX})
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC ${CMAKE_INSTALL_DOCDIR})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
++
++
++if(ENABLE_EXAMPLES)
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+-
+ if(GLUT_FOUND)
+ add_executable(gl2psTest WIN32 gl2psTest.c)
+ target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+ add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+ target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+ endif(GLUT_FOUND)
++endif(ENABLE_EXAMPLES)
+
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +160,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})
diff --git a/x11-libs/gl2ps/gl2ps-1.3.9.ebuild b/x11-libs/gl2ps/gl2ps-1.3.9.ebuild
new file mode 100644
index 000000000000..d46ef9b88279
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+RDEPEND="
+ media-libs/freeglut
+ x11-libs/libXmu
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-tex/tth
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended )"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3.8-cmake.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed '/^install.*TODO\.txt/d' -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DUSE_ENABLE_DOC="$(usex doc)"
+ -DUSE_ENABLE_PNG="$(usex png)"
+ -DUSE_ENABLE_ZLIB="$(usex zlib)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}
diff --git a/x11-libs/gl2ps/metadata.xml b/x11-libs/gl2ps/metadata.xml
new file mode 100644
index 000000000000..dd1e3ccd3a3f
--- /dev/null
+++ b/x11-libs/gl2ps/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ GL2PS is a C library providing high quality vector output for any
+ OpenGL application. The main difference between GL2PS and other
+ similar libraries is the use of sorting algorithms
+ capable of handling intersecting and stretched polygons, as well as
+ non manifold objects. GL2PS provides advanced smooth shading and
+ text rendering, culling of invisible primitives, mixed vector/bitmap
+ output, and much more.
+</longdescription>
+</pkgmetadata>