summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-openchrome
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-openchrome')
-rw-r--r--x11-drivers/xf86-video-openchrome/Manifest2
-rw-r--r--x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild29
2 files changed, 15 insertions, 16 deletions
diff --git a/x11-drivers/xf86-video-openchrome/Manifest b/x11-drivers/xf86-video-openchrome/Manifest
index ebe1182387db..6e2abbd60dd5 100644
--- a/x11-drivers/xf86-video-openchrome/Manifest
+++ b/x11-drivers/xf86-video-openchrome/Manifest
@@ -1,4 +1,4 @@
AUX xf86-video-openchrome-0.6.0-fno-common.patch 1298 BLAKE2B 605a1b1964b5b7baabc7650164fc6e8ef444d19fd437151d6dc0697c0349810d82b70cbb803c77cbb65f604bf7edfdc42b7790270d9f795d71f931e05b893623 SHA512 119b7bb83af9c8aec01f6b0b55d77ec1081680c21a4e0d0f9a01b0f0c34e9f9cb9a7c5fb97e64387e1f3e46445d930fa1f1921c5424cfdfc547dd497f16e43a8
DIST xf86-video-openchrome-0.6.0.tar.bz2 537619 BLAKE2B 30d8ab246646bde41b1ce0fd48c133cb7c2c3cff7c7201daf7e4fcded7a3e47bdc28d739247fce69b17a0e7697b33af35e3f771496654920b275a5aacbe8fc6f SHA512 f074e70d54c87a9d6e1b52c2c2d72d7c551dcb59a5f34c0a5f9495db1a6e45db4300d51fabf7eedfbe91f964f9422931c752a49b322715c6aa9ddb0db9dd6004
-EBUILD xf86-video-openchrome-0.6.0.ebuild 1212 BLAKE2B 7bf0313d3a7ea334cc17980076b6fcf59200167160b7c8860e91f84f2f40f7dd942e56050ac43a49144b41a523b965cbe3e3d956441926a561d6348602412540 SHA512 ae3e9967fb20bc5d8defebf670643206b74d61e1db4195d01d6440b9c57cbc5f0c2d32d660e45d75b7ab504db7aa118b247304f9cfd32a8d0e990bf93627b084
+EBUILD xf86-video-openchrome-0.6.0.ebuild 1188 BLAKE2B 81753d96af1c696f6bc74ac0e90ab8fbcd80952ec6e3c6ea7bcfb7c9b80df6fb6043e48c134f09a56f6509a4b0a371c1db50856d6562cfdcf17003b259baf560 SHA512 fdb27377ea94fb80590f44a0cf947d26397cdad6df5b76525ff6a1dda740f8572f696a9a2f56e8407abcf643b362c5d0509613fa9f1eada97036aa9628b136f8
MISC metadata.xml 302 BLAKE2B 7a580d2b118b1768147df42d10928eeb618524c00a2865c3f4a4eaa3334c86e6d8714019553baa95a7c8cfc30aa7d685eaecf3913c856623392b2ec8e00de744 SHA512 43446377349f40ba3bf5ccd9648ea102a8cf1fa07bcf8ec1d1df3ef3dec994d11437a4cb1190901f0a7cda7fa1332de1642771be82e87b16063d69922e072754
diff --git a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
index b2f2a36914b7..1219380c354b 100644
--- a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
+++ b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
@@ -1,42 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
XORG_DRI="always"
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="X.Org driver for VIA/S3G cards"
HOMEPAGE="https://www.freedesktop.org/wiki/Openchrome/"
-LICENSE="MIT"
+LICENSE="MIT"
KEYWORDS="amd64 x86"
IUSE="debug viaregtool"
-RDEPEND=">=x11-base/xorg-server-1.9"
-DEPEND="
- ${RDEPEND}
+RDEPEND="
+ >=x11-base/xorg-server-1.9
x11-libs/libX11
x11-libs/libXext
- x11-libs/libXv
x11-libs/libXvMC
- x11-libs/libdrm
-"
-
-DOCS=( ChangeLog NEWS README )
+ x11-libs/libdrm"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXv"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable debug)
$(use_enable debug xv-debug)
$(use_enable viaregtool)
)
- xorg-2_src_configure
+ xorg-3_src_configure
}
pkg_postinst() {
- xorg-2_pkg_postinst
+ xorg-3_pkg_postinst
elog "Supported chipsets:"
elog "CLE266 (VT3122), KM400/P4M800 (VT3205), K8M800 (VT3204),"