summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 90a061997083..df2b7fe4867b 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,11 +13,17 @@ fi
DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+IUSE="udev"
+
RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_amdgpu]
- x11-base/xorg-server[glamor(-)]"
+ x11-base/xorg-server[glamor(-)]
+ udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}"
src_configure() {
- XORG_CONFIGURE_OPTIONS="--enable-glamor"
+ XORG_CONFIGURE_OPTIONS=(
+ --enable-glamor
+ $(use_enable udev)
+ )
xorg-2_src_configure
}