summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild
new file mode 100644
index 000000000000..5dc34b7fecce
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-21.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_DRI="always"
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_amdgpu]
+ x11-base/xorg-server[-minimal]
+ udev? ( virtual/libudev:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-glamor
+ $(use_enable udev)
+ )
+ xorg-3_src_configure
+}